Welcome to Geeklog Sunday, October 21 2018 @ 04:07 am EDT

Geeklog Forums

parse_ini_file in forum


ancona5

Anonymous
I have geeklog 1.4.0sr5-1 and Geeklog Forums Plugin 2.3

when I read a topic, I have this error:

PHP Formatted Code
Warning: parse_ini_file() has been disabled for security reasons in /home/ancona5/public_html/forum/include/gf_showtopic.php on line 105
 


I have this error repeated for each post in the topic!!!

ancona5

Anonymous
this is the code in gf_showtopic

PHP Formatted Code
105 $config = parse_ini_file($_CONF['path'] . 'plugins/forum/BBCodeParser.ini', true);
106 $options = &PEAR::getStaticProperty('HTML_BBCodeParser', '_options');
107 $options = $config['HTML_BBCodeParser'];
108 unset($options);
 

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Quote by ancona5: Warning: parse_ini_file() has been disabled for security reasons

Your hosting service has decided to disable that function, but something in the Forum plugin seems to rely on it being available.

If there's no way for you to turn that function back on, you may have to ask Blaine for help ...

bye, Dirk

Ancona5

Anonymous
How can I turn on that?! where may be that function setting?

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
You would need access to the php.ini. If you don't have that, you can only try contacting your hosting service.

bye, Dirk

Ancona5

Anonymous
I haven't access to that file .... what have I to say to my hosting service?

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Ask them if there's any way to enable parse_ini_file()

If and how they do that depends on their configuration (and policy).

bye, Dirk

Ancona5

Anonymous
they have answered me to read this document:

http://it.php.net/manual/en/function.parse-ini-file.php

but I don't understand what I have to do ..

Status: offline

Robin

Forum User
Full Member
Registered: 15/02/02
Posts: 725
Quote by Ancona5: but I don't understand what I have to do ..


Not sure whether this will help however you could try to change this:

PHP Formatted Code
105 $config = parse_ini_file($_CONF['path'] . 'plugins/forum/BBCodeParser.ini', true);
 


into this
PHP Formatted Code
105 $config = parse_ini_file($_CONF['path'] . 'plugins/forum/BBCodeParser.ini', false);
 

Geeklog Polish Support Team

Ancona5

Anonymous
nothing happen putting it to FALSE ..

I have deleted that row and now it works fine

All times are EDT. The time is now 04:07 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content