Welcome to Geeklog Sunday, November 28 2021 @ 11:58 am EST

Geeklog Forums

privmessage install help


Status: offline

5jays217

Forum User
Junior
Registered: 29/07/06
Posts: 21
Location:Illinois
The directions say to goto public_html/privmessages/install.php, when i go to this in the address bar I get the following msg:

Fatal error: Call to undefined function: sec_ingroup() in /home/fivejays/public_html/php/plugins/privmessages/install.php on line 37

line 37 = if (!SEC_inGroup('Root')){
$display .= COM_siteHeader();
$display .= COM_startBlock('Access Denied');
$display .= $lang_pm[access_denied_msg];
$display .= COM_endBlock();
$display .= COM_siteFooter(true);
echo $display;
exit;
}

What should Root =?

I tried the full path to the root directory and got a different error..

I know I should be able to run the install from admin/plugins but it doesn't show up there yet. I've added the files to geeklog/plugins and it doesn't advise to add anywhere else.

Any ideas
Jamie Robinson
 Quote

Status: offline

5jays217

Forum User
Junior
Registered: 29/07/06
Posts: 21
Location:Illinois
i've added it as a block and now am working to fix new errors
Jamie Robinson
 Quote

Status: offline

5jays217

Forum User
Junior
Registered: 29/07/06
Posts: 21
Location:Illinois
Sat 29 Jul 2006 22:19:29 EDT - 1146: Table 'fivejays_gklg3.privmessages' doesn't exist. SQL in question: SELECT * FROM privmessages WHERE to_uid = 2

This is the current error in addition to the first.
Jamie Robinson
 Quote

Status: offline

scroff

Forum User
Regular Poster
Registered: 19/02/03
Posts: 111
I think you have your directory structure all messed up. The error says that GL is looking for install under public_html/php/plugins/prive... etc etc etc. This can't be right. When you first saw your server, was there a public_html folder there or did you create it? Did you have to rename the public_html/admin folder to /php?

Root in this case is the root users group, its a security group. When you look at Groups in your GL admin menu you should see a list of groups, "root" should be in there. Users in this group have full admin rights.

As far as the second error... 'fivejays_gklg3.privmessages' is a table in your database. GL tables are preceded by gl_ unless you changed that in the config.php. Your table should be 'gl_fivejays_gklg3.privmessages' If you did change the prefix then it looks like it wasn't created.

I think you might want to read the FAQ on installing
Geeklog entirely within the web root, because that's what it looks like you are trying to do. I'm not one of the geekgods, but I'm willing to help out if you email me through this site. I can usually get an install up and running and can point you in the right direction.
 Quote

Status: offline

5jays217

Forum User
Junior
Registered: 29/07/06
Posts: 21
Location:Illinois
When you first saw your server, was there a public_html folder there or did you create it?



My geeklog site is actually a subsite. public_html/php is the root for this site, where public_html/test would be a different site not related to gl.

Then the admin for gl is at public_html/php/admin.



root refers to user groups. got it.



I'm checking on the table issue....
Jamie Robinson
 Quote

Status: offline

5jays217

Forum User
Junior
Registered: 29/07/06
Posts: 21
Location:Illinois
fivejays_gklg3 is the db created by gl on my server when installed. All the tables are prefixed by 'gl_'.

So the privmessages should be 'fivejays_gklg3.gl_privmessages', right?
Jamie Robinson
 Quote

Status: offline

scroff

Forum User
Regular Poster
Registered: 19/02/03
Posts: 111
Ok, lemme think....

I think I'm getting a handle on what you're doing. Public_html is your root, and you have files for more than one site in there, with php being the folder for the geeklog public_html files, and public_html being the folder for all the other geeklog files? Or are they above public_html? Did you change the path in config.php to reflect that? Is $_CONF['path_html'] = '/path/to/your/public_html/'; correct? And did you change
// You only need to change this if you moved or renamed the public_html
// directory. In that case, you should specify the complete path to the
// directory (i.e. without the $_CONF['path']) like this:
// $_CONF['path_html'] = '/path/to/your/public_html/';
$_CONF['path_html'] = $_CONF['path'] . 'public_html/';


and then you'll have to change the lib-common path to your config.php so it knows where to look for it.

If I understand you correctly, you need to be sure that the files that are supposed to be above the web root are not in public_html.

So the privmessages should be 'fivejays_gklg3.gl_privmessages', right?


Yes. Sorry about that. I think it's not installing because either the directory or th epaths are mixed up. Check them out.
 Quote

Status: offline

5jays217

Forum User
Junior
Registered: 29/07/06
Posts: 21
Location:Illinois
Quote by scroff: Public_html is your root, and you have files for more than one site in there, with php being the folder for the geeklog public_html files,



yes

I tried to add a public_html folder under php, as well as, placing the files i was told to in the root next to php.


neither worked.
Jamie Robinson
 Quote

Status: offline

5jays217

Forum User
Junior
Registered: 29/07/06
Posts: 21
Location:Illinois
Quote by scroff: If I understand you correctly, you need to be sure that the files that are supposed to be above the web root are not in public_html.

OK here's where my inexperience comes in...

above the root... does that mean public_html/plugin next to public_html/php?
Jamie Robinson
 Quote

Status: offline

scroff

Forum User
Regular Poster
Registered: 19/02/03
Posts: 111
It means that plugins should go outside of public_html. That and everything else that was outside public_html in the original tarball. Then you just change the paths to reflect that in lib-common and config.php.

All you're doing is putting the geeklog public files into their own directory becasue you can't have two index.php files. So if php is where you put all the geeklog public_html files, then all the rest goes above public_html on your server. Then you add php after public_html in your config file.

Thus, $_CONF['path'] = '/path/to/geeklog/'; stays the same, that is it points to where your config.php file is, above your servers public_html folder

and

$_CONF['path_html'] = '/path/to/your/public_html/'; becomes path/to/your/public_html/php/

In lib-common you put the path to your config.php, the same one you used in config.php, but with config.php apended, like so

'/path/to/geeklog/config.php'

That should work.

 Quote

Status: offline

5jays217

Forum User
Junior
Registered: 29/07/06
Posts: 21
Location:Illinois
scroff,

thanks for all your input!

I took what you were saying and tried something that i think made sense....

public_html/php is what my host calls my main folder for this site...
public_html/php/admin is the path to my admin folder...
I added a folder at public_html/php/privmessages and loaded the tarball extraction there...

I tried the path/to/privmessages/install.php and it worked.
It stated that it installed succesfully.

Now i just need to test it to see if it worked.
Jamie Robinson
 Quote

Status: offline

5jays217

Forum User
Junior
Registered: 29/07/06
Posts: 21
Location:Illinois
OK the privmessages is working as a block (which had to added manually) on the homepage but, I thought it would work with the forum.

The forum has an option to enable pm's but it didn't work. Is that a different plugin?

scroff, i now understand what you were saying about it being outside the public_html, i've added that and a stocks plugin that both seem to work. Please check it out.
Jamie Robinson
 Quote

All times are EST. The time is now 11:58 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content