Welcome to Geeklog Thursday, December 02 2021 @ 05:32 am EST

Geeklog Forums

Comment Preview Not Working Properly after Updating to 1.4.0sr5


Status: offline

TrappedOnEarth

Forum User
Junior
Registered: 13/07/05
Posts: 15


Forgive the duplication, as I already posted concerning this situation in the comments section of the Geeklog 1.4.0sr5 article (here). But part of the reason for me posting the problem there was to see if the problem was limited to my site or not. But I saw the same issue when I tried it here.

After replacing my lib-comment.php file which is required upon updating from 1.4.0sr4 to 1.4.0sr5, now when I post a comment, the preview function is not displaying properly. It only displays the first few lines of text omitting the rest and if you are using html formating, it ignores all the html formatting.

Yet, if you submit the comment, it will then post properly to the site, complete and with the html formatting displaying correctly. The problem seems to be limited to previewing your comment before submitting it.

I tested it using Safari and Firefox so far with the same results, I also tried it the Professional theme to be sure it was not a theme issue, and finally I tested it here on this site. And I tested it out on two different computers. All with the same results.

I am guessing it is a little bug in the new lib-comment.php file.

Thanks.

Cheers,
Louis
 Quote

Status: offline

::Ben

Forum User
Full Member
Registered: 14/01/05
Posts: 1569
Location:la rochelle, France
Hello,

Comment preview is still not working for me with FireFox or Internet Explorer on Geeklog 1.4.1 with advenced editor on.

::Ben
I'm available to customise your themes or plugins for your Geeklog CMS
 Quote

Status: offline

::Ben

Forum User
Full Member
Registered: 14/01/05
Posts: 1569
Location:la rochelle, France
I don't know where is the matter but I found this little solution waiting to a big one: I disabled the preview button in the comment layout and allowed users, in the config.php, to skip preview.

Might it be a issue with my hosting?

::Ben
I'm available to customise your themes or plugins for your Geeklog CMS
 Quote

All times are EST. The time is now 05:32 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content