Welcome to Geeklog Saturday, November 16 2019 @ 11:53 pm EST

Geeklog Forums

Fatal error using admin functions


jlanda

Anonymous
Hi, I updated my GL version to 1.4.0sr2. I am now unable to use the admin functions. As an example, when I click on an admin function I get an error such as this: Fatal error: Call to undefined function: admin_list() in /www/e/earthspillars/htdocs/socialprogress/admin/plugins/polls/index.php on line 95

Any idea what's going on? I have 3 sites and they're all doing this. Worked fine before the update.

For background, I had 1.4.0, which I first upgraded to sr1, then to sr2.

Thanks for your help! Great program by the way!

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Make sure you have a file system/lib-admin.php (that one was introduced in 1.4.0, actually).

bye, Dirk

jlanda

Anonymous
Yep, the file is there fully intact. I even copied over a fresh copy from the full sr2 installation just to see if that was the issue, but still no dice. I followed the instructions for the upgrades, but is there perhaps something else I should copy over perhaps from the full install?

jlanda

Anonymous
Okay, I seem to have fixed the problem. I replaced the files in the admin directory and it worked fine after that. The smallest things...thanks for your help anyway!

Status: offline

J23

Forum User
Newbie
Registered: 24/07/05
Posts: 6
Location:Canada
Hi,

well I had the same problem and as you did after I replaced files in the admin directory it started to work fine again ..
http://www.info-polonia.com/

All times are EST. The time is now 11:53 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content