Welcome to Geeklog Monday, September 28 2020 @ 06:43 pm EDT

Geeklog Forums

Comments error


Status: offline

lgriffin

Forum User
Junior
Registered: 01/12/04
Posts: 24
curious
I have upgraded to geeklog 1.4.0. When I make a comment to a story, it gives the following error:
'gpdallas_geeklog@%' to database 'gpdallas_geeklog". SQL in Question: LOCK TABLES gl_comments WRITE

Any ideas what is wrong?

Thanks
Larry
 Quote

troy14

Anonymous
You need to contact your hosting provider and get LOCK permissions for your tables. Once that is set, the errors will go away. It is not a setting that was used in previous versions, and hosts do not have user accounts set up for those permissions by default.

It happened to me too.
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
For the sake of completeness, here's the FAQ entry: comment.php error: can not lock table gl_comments

bye, Dirk
 Quote

Status: offline

lgriffin

Forum User
Junior
Registered: 01/12/04
Posts: 24
happy
Thanks, you guys are great
Larry
 Quote

Status: offline

lgriffin

Forum User
Junior
Registered: 01/12/04
Posts: 24
caffeinated
Well the hosting house (GoDaddy) will not grant the lock table to me. There only reason is they don't want to.

I have looked thru the comment.php and i do not find where it is calling for lock table. Am I just overlooking it or is the lock table coming from some where else?

Thanks
Larry
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
It's in system/lib-comment.php

bye, Dirk
 Quote

Status: offline

bjudson

Forum User
Junior
Registered: 01/01/04
Posts: 34
I've posted a fix for this before (note the line #'s may have changed by a few lines):

If your hosting provider REFUSES to give you Grant or LOCK access, as GoDaddy, Shieldhost, and a million others will do, and you can't or won't change providers then you can edit the following files.

(Note Dirk, you should make this a config option, discourage it's use, but make it an option the big cheap providers just don't care about independent sites)

/pathtogl/system/lib-comment.php

Line 837 add // to the front so:
// DB_query("LOCK TABLES {$_TABLES['comments']} WRITE");
Line 863 add // to the front so:
//DB_query('UNLOCK TABLES');

Line 968 add // to the front so:
// DB_query("LOCK TABLES {$_TABLES['comments']} WRITE");

Line 987 add // to the front so :
// DB_query('UNLOCK TABLES');


As a side note I recently switched from GoDaddy ($3.95 per month) to 1&1 ($2.99 per month) and this is no longer a problem!
 Quote

Status: offline

lgriffin

Forum User
Junior
Registered: 01/12/04
Posts: 24
cheerful
Thanks for the help, that worked. Also I will look into 1&1

Again Thanks
Larry
 Quote

Deirdre

Anonymous
happy
Thanks, I was having the same problems as well, again with GoDaddy...

I guess I'll be looking into 1and1 as well.

YAY!
 Quote

All times are EDT. The time is now 06:43 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content