Welcome to Geeklog Monday, August 19 2019 @ 10:26 am EDT

Geeklog Forums

GL_gallery2 plugin images don't show


Status: offline

jordydme

Forum User
Full Member
Registered: 03/11/05
Posts: 135
I recently install this Gallery2 plugin and I have a place holder in random image block instead of an actual image. My sense is that there is a broken link.

I also noticed that when I click the Gallery 2 link in one of my blocks, the link is broken and the path looks incorrect. IT does not bring me to my gallery. When i click the photo place holder, the link also brings me to a broken URL.

I went over and over the pluggin config file. I think I have my paths correct. Is there more that needs to be done from the gallery admin panel that I am missing?

The documantation on this pluggin is a little scarce. I feel that I have searched adequately with no results.

Any help would be appreciated,

Status: offline

Centauri

Forum User
Newbie
Registered: 14/01/05
Posts: 6
Location:The Netherlands
Make sure you have this one right

$_GLG_CONF['G2_path'] = '/home/contracts/XXX/www/gallery2';

$_GLG_CONF['G2_relative_path'] = '../gallery2';

Status: offline

jordydme

Forum User
Full Member
Registered: 03/11/05
Posts: 135
This is what I have in my GL_gallery2 config file:

PHP Formatted Code

$_GLG_CONF['G2_path'] = '/home/jordydme/public_html/gallery2';

$_GLG_CONF['G2_relative_path'] = '../gallery2';



 


The public_html directory is my website directory. Gallery2 directory is in that. So unless I am missinig something, I think this is correct?


What do you think?


2nd Question:

Are the examples in the paths below supposeed to be intended for the Gl_gallery2 config file or are they for modifyig the already installed gallery2 config file?


PHP Formatted Code
* A note about paths:
        Gallery2 requires a bunch of path info when you initialise it.  These paths can be quite
        confusing [just as Geeklog's can].  Here's an example to show what these should be set to.
       
        My Geeklog's $_CONF['path_html'] is '/var/www/docs/geeklog/'
        My Gallery2 is installed in the directory '
/var/www/docs/gallery2/'
       
        $_GLG_CONF['
G2_path'] is the full path to the Gallery2 installation.
        $_GLG_CONF['
G2_relative_path'] is the relative path from the $_CONF['path_html'] to the Gallery2 directory.
       



I know I am missing something here and I cannot seem to figure it out on my own. Feeling pretty frustrated.

Any and all suggestions on how to troubleshoot this woudl be appreciated,

Thanks,
Jordy

Status: offline

ajzz

Forum User
Regular Poster
Registered: 19/01/05
Posts: 113
If you can see the gallery framework but not the pictures within, there is an issue with paths.

Since the paths in the plugin config file seem reasonable (always worth a recheck), the only other thing to be sure of is that you did a complete deinstall (not just deactivation) of the url-rewrite within G2 before installing the plugin. Then you can reinstall url_rewrite from the integrated version after.

Cheers!

Ajay

Status: offline

jordydme

Forum User
Full Member
Registered: 03/11/05
Posts: 135
Ok, so correct me if I'm wrong. You are saying that I should uinstall the pluggn then uninstall the G@ url rewrite. Then I should reinstall GL pluggin and then reinstall gallery rewrite..correct?

Just don't want to mess anything up.

Thnanks for the reply,
jordyd

Status: offline

jordydme

Forum User
Full Member
Registered: 03/11/05
Posts: 135
well, I wen't out on a limb and did exactl what you suggested and now my gallery is inoperable. The rewrite module had me jump through some hoops when I tried to reinstall and then reactivate it after installing the GL_gallery2 pluggin.

The rewrite module had me create ".htaccess" directory and chmod it to 666 so I did. It then said success! I figured I was done. when I clicked a link I got this:

PHP Formatted Code
Error

An error has occurred.

Back to the Gallery
Error Detail -
Error (ERROR_CONFIGURATION_REQUIRED)

    * in modules/rewrite/module.inc at line 224 (gallerystatus::error)
    * in modules/core/AdminModules.inc at line 109 (rewritemodule::activate)
    * in main.php at line 174 (adminmodulescontroller::handlerequest)
    * in main.php at line 87
    * in main.php at line 80

System Information
Gallery version         2.0
PHP version     4.4.0 apache
Webserver       Apache/1.3.33 (Unix) mod_auth_passthrough/1.8 mod_log_bytes/1.2 mod_bwlimited/1.4 PHP/4.4.0 FrontPage/5.0.2.2635 mod_ssl/2.8.22 OpenSSL/0.9.7a
Database        mysql 4.0.25-standard
Toolkits        SquareThumb, ImageMagick, NetPBM, Gd
Operating system        Linux krg.opensourcehost.com 2.6.13-ts.grh.mh.ht #2 SMP Sat Aug 27 04:37:33 EST 2005 i686
Browser         Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
 


I am at a loss so I guess I am reinstalling Gallery now too.

Thanks,
Jordy

Status: offline

ajzz

Forum User
Regular Poster
Registered: 19/01/05
Posts: 113
Sorry if I was not clear.

0) You can leave the GL_Gallery2 plugin installed as before.

1) You can access gallery2 independently (standalone) without using the gallery plugin by browsing to http://yoursite/gallery2 like it used to be before you tried to integrate it with Geeklog (you dont have to uninstall gallery or resinstall it.)

2) Once you are logged in to gallery2 (standalone) you can go to the admin interface and uninstall the url-rewrite module.

3) You can then go back to geeklog and browse to http://yoursite/GL_Gallery2 and login with the administrative password.

4) Then while still in the GL_Gallery2 interface you can access the gallery admin and install the url-rewrite module therein.

Let me know if you need clarification (i.e. if it doesnt make sense to you dont try it yet)

Ajay

PS: You can e-mail me a link to your site if you like.

Status: offline

jordydme

Forum User
Full Member
Registered: 03/11/05
Posts: 135
I had already tried to get back into the admin panel of G2 the url was now broken. So I couldn't uninstall the url rewrite module as you were described.

the initial error message I received was:

PHP Formatted Code
 Error

An error has occurred.

Back to the Gallery
Error Detail -
Error (ERROR_CONFIGURATION_REQUIRED)

    * in modules/rewrite/module.inc at line 224 (gallerystatus::error)
    * in modules/core/AdminModules.inc at line 109 (rewritemodule::activate)
    * in main.php at line 174 (adminmodulescontroller::handlerequest)
    * in main.php at line 87
    * in main.php at line 80

System Information
Gallery version         2.0
PHP version     4.4.0 apache
Webserver       Apache/1.3.33 (Unix) mod_auth_passthrough/1.8 mod_log_bytes/1.2 mod_bwlimited/1.4 PHP/4.4.0 FrontPage/5.0.2.2635 mod_ssl/2.8.22 OpenSSL/0.9.7a
Database        mysql 4.0.25-standard
Toolkits        SquareThumb, ImageMagick, NetPBM, Gd
Operating system        Linux krg.opensourcehost.com 2.6.13-ts.grh.mh.ht #2 SMP Sat Aug 27 04:37:33 EST 2005 i686
Browser         Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

 



None of the documentation say anything about the 2 things you mention:

3) You can then go back to geeklog and browse to http://yoursite/GL_Gallery2 and login with the administrative password.

4) Then while still in the GL_Gallery2 interface you can access the gallery admin and install the url-rewrite module therein

_________
I already started deleting gallery becasue I got so fed up and didn't know wehn the next time I would have help would be.

Thanks for your time, I will try all this again and let you know whats up.

Jordy


All times are EDT. The time is now 10:26 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content