Welcome to Geeklog Wednesday, April 24 2019 @ 12:31 pm EDT

Geeklog Forums

GL_Gallery2_0.4.1_1.3.11 Install problem_PLEAASE SOMEONE LOOK AT THIS!


Status: offline

jordydme

Forum User
Full Member
Registered: 03/11/05
Posts: 135
Hi,

I jsut spend several days learning how to set up GL and then instal the PHPbridge. I fanally got this up and runnig flawlesslly.

I attempted to install the GL_Gallery2 pluggin as my last addition. I had a bit of a hard time understanding the wording of the directions.

When I went to the Admin plugin page to install the GL_gallery2, I clicked install and got a blank white page. Then I couldn't get access to my Gl site at all. Now all I get is a white page.

I amy hae donw a stupid thing from here. I then delted the GL_Gallery2 pluggin directories from my server hoping I could start over cause I couldn't very well uninstall cause I had no accesss to my site any longer, just a blank white page.


I got nothing on my error log exept for this: " *** dummy entry *** "

I did however, backup my GL database before doing the pluggin install.

Can anyone direct me to what i should d, I really don't wnat to go through a areinstall of GL and PHP bridge again. this was really hard for me.


I did not see the bottom portion of the directions untill after I hit the install link. The directions state as follows:

Installing The Plugin

1. First off, make sure you have a working Gallery2 installation and a working Geeklog installation.
2. If you have G2's URL Rewrite module installed, deactivate and remove it. Re-install it through the embedded version after you've completed the installation of the plugin. This will ensure that the correct paths are used for rewriting.
3. Backup your Geeklog database because the GL_Gallery2 plugin adds and modifies tables. You can do this with the built in database backup facility in the Admin menu.
4. Uncompress the GL_Gallery2 plugin archive while in the /plugins directory. The archive will create a directory called GL_Gallery2.
5. In your directory, create a directory called GL_Gallery2. Under your /admin/plugins/ directory create a directory called GL_Gallery2.
6. Change to your /plugins/GL_Gallery2/ directory.
7. Copy the files in the admin directory to the admin/plugins/GL_Gallery2/ directory you created in step 3.
8. Copy the files and directories in the public_html directory to the public_html/GL_Gallery2/ directory you created in step 3.
9. Login as the user who will be the admin for the G2 installation. Go to the plugin administration page. The GL_Gallery2 plugin should show up with a link to install it. Click it. The install page will tell you if the install was successful or not. If not, examine the Geeklog system errorlog in /logs to see what the problem was. Fix it and re-install.
10. Note: This plugin creates blocks which you should not remove manually. It is fine to disable them, but the plugin expects them to exist. They will be removed if you choose to remove the plugin.

Configuring The Plugin This section comes after it tells you to install Was I suppossed to do this before installing??

The only thing you must do is configure your paths by setting $_GLG_CONF['G2_path'] and $_GLG_CONF['G2_relative_path'] in your GL_Gallery2 config.php. These are explained in the file.

$_GLG_CONF['public_dir'] allows you to name the public_html portion of the GL_Gallery2 plugin whatever you want.


------------

I know these install directions could be worded better and i would be willing to help with that as i am a newbie and know what would be helpful for somonw like me to better understand these directions.


Thanks,
Jordy

Status: offline

drshakagee

Forum User
Full Member
Registered: 01/10/03
Posts: 231
Try searching the faq's for blank page.

Adding that "_PLEAASE SOMEONE LOOK AT THIS!" doesn't really get more people to look at your post, in fact it gets people to ignore it.
Yes I am mental.

Status: offline

vadertech

Forum User
Full Member
Registered: 26/05/03
Posts: 329
If you want to venture into the database, you can go into gl_plugins table, open the gallery2 plugin info and change the value of "enabled" from 1 to 0.

See if that works.

The proper way to uninstall plugins is through the admin plugins page.
GeekLog Hosting, Installations and Upgrades - WWW.AWEHOST.COM - Hosting starts @ only $4.95/mo.

Status: offline

jordydme

Forum User
Full Member
Registered: 03/11/05
Posts: 135
Hi,

I tried to edit that DB in PHP MYADMIN but did not know what I was doing so I left it alone. Instead I uploaded the GL_gallery files that I had deleted becasue I figure that I never really installed the pluggin. So I guess it worked somewhat becasue my GL site is back up but now it's messed up. See below.

On my plugin install page it says that the pluggin is installed but I get a wierd thing happening when logged in. The GL pages load but at the top of the page it's white and the following code is repeatedly running across the top of the page:

Warning: fopen(/home/jordydme/geeklog_data/logs/error.log): failed to open stream: Permission denied in /home/jordydme/public_html/geeklog/lib-common.php on line 1547

Warning: fopen(/home/jordydme/geeklog_data/logs/error.log): failed to open stream: Permission denied in /home/jordydme/public_html/geeklog/lib-common.php on line 1547

Warning: fopen(/home/jordydme/geeklog_data/logs/error.log): failed to open stream: Permission denied in /home/jordydme/public_html/geeklog/lib-common.php on line 1547

Warning: fopen(/home/jordydme/geeklog_data/logs/error.log): failed to open stream: Permission denied in /home/jordydme/public_html/geeklog/lib-common.php on line 1547

Warning: fopen(/home/jordydme/geeklog_data/logs/error.log): failed to open stream: Permission denied in /home/jordydme/public_html/geeklog/lib-common.php on line 1547

Warning: fopen(/home/jordydme/geeklog_data/logs/error.log): failed to open stream: Permission denied in /home/jordydme/public_html/geeklog/lib-common.php on line 1547

Warning: Cannot modify header information - headers already sent by (output started at /home/jordydme/public_html/geeklog/lib-common.php:1547) in /home/jordydme/public_html/geeklog/lib-common.php(987) : eval()'d code on line 1

Know what I should do with this?



Thanks,
Jordyd



Status: offline

vadertech

Forum User
Full Member
Registered: 26/05/03
Posts: 329
Disable and uninstall the plugin completely. Reinstall it from start.

From Documentation:

I've set up my site successfully, but get the following error message on the top:

Warning: fopen("/some/path/logs/error.log", "a") - Permission denied in /some/path/public_html/lib-common.php on line 1440

(line number may vary)

Answer:

Make sure that the logs/ directory AND the files in it have permissions of at least 775. You may need to make the permissions 777 if 775 isn't working for you. For good measure, make sure the public_html/backend directory and the geeklog.rdf file have the same 775 or 777 permissions.

Tip: Use the script that is located at http://yourgeeklogsite/admin/install/check.php to test if all the permissions have been set up correctly.



Whenever someone tries to log in or out, the following error is produced:

Warning: Cannot modify header information - headers already sent by (output started at /home/user/public_html/geeklog/lib-common.php:1547) in /home/user/public_html/geeklog/lib-common.php(987) : eval()'d code on line 1

(line numbers may vary)

Answer:

Make sure that your lib-common.php file does not contain any "whitespace" after the closing ?> at the end of the file. I.e. there should not be anything (not even blanks or empty lines) after those two characters.
GeekLog Hosting, Installations and Upgrades - WWW.AWEHOST.COM - Hosting starts @ only $4.95/mo.

Status: offline

jordydme

Forum User
Full Member
Registered: 03/11/05
Posts: 135
Thanks, I uninstalled it and am going to try it again. I will watch aout for the white space. I'll let you know how it comes out. I really apreciate the fast replies. Much appreciated.

Jordy

Status: offline

jordydme

Forum User
Full Member
Registered: 03/11/05
Posts: 135
Ok so it looks like it's working somewhat. Thanks for the advice on the white space. However the link to the gallery doesn't work and the pictures don't show in the gallery block. I edited the pluggin config file. OR is there another file to edit? Coul it be I messed up the path to the gallery.?

Also, I noticed that when a user logs in there is no link to the PHPBB2 forum. There is a link when I login as the admin but not if you login as a general user. You can test this out at my site:

here





Status: offline

jordydme

Forum User
Full Member
Registered: 03/11/05
Posts: 135
Ok, just found the forum link all the way in the top right corner. Is there a wway to make the forum apper on the front page or home page. Or is there away to put a more visible link in a block on the left?

Thanks,
Jordy

All times are EDT. The time is now 12:31 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content