Welcome to Geeklog, Anonymous Monday, January 30 2023 @ 09:13 am EST

Geeklog Forums

No themes on MAC OSX install


Frlitz

Anonymous
I am hoping that another pair of eyes will find what I have missed. The problem appears to be, a path problem, but it is not. After several days of reinstalling, reading, and troubleshooting, I can not find the cause of this behavior that appears to be a path problem.

Using the FAQ "moving geeklog site", as a guide, I moved a working geeklog site from FC3 to a MACOSX [Apache/1.3.27 (Darwin)] environment. All of the values in '/Users/geeklog/config.php' were changed to reflect the MACOSX's directory structures i.e.:
$_CONF['path'] = /Users/geeklog/
$_CONF['path_html'] = /Library/WebServer/Documents/mydomain/
$_CONF['site_url'] = 'http://mydomain.net';
$_CONF['cookiedomain'] = '.mydomain.net'

The problem, the geeklog pages are displayed without a theme and the following errors explains why:
Text Formatted Code

File does not exist:  /Library/WebServer/Documents/mydomain/professional/style.css
File does not exist:  /Library/WebServer/Documents/mydomain/professional/images/logo.gif
File does not exist:  /Library/WebServer/Documents/mydomain/professional/images/print.gif
File does not exist:  /Library/WebServer/Documents/mydomain/professional/images/mail.gif

 


OK, I know that the above errors are correct when reporting that style.css is not found in the /Library/WebServer/Documents/mydomain/professional/ directory. I have not been able to discover: Why the system is looking for the themes in the DocumentRoot folder?

When clearing the cookies, I discovered that sessions were created for mydomain.net:16080. Using http://mydomain.net:16080, the theme appears on the index.php, calendar.php, but not forum/index.php.

Below the virtual host info:
Text Formatted Code

<VirtualHost x.x.x.x:16080>
ServerName mydomain.net
ServerAdmin webmaster@macosx.net
DocumentRoot "/Library/WebServer/Documents/mydomain"
DirectoryIndex index.html index.php
CustomLog "/private/var/log/httpd/access_log" "%{PC-Remote-Addr}i %l %u %t "%r" %>s %b"
ErrorLog "/private/var/log/httpd/error_log"
SSLEngine Off
SSLLog "/private/var/log/httpd/ssl_engine_log"
SSLCipherSuite "RSA:-HIGH:-MEDIUM:-LOW:+EXP"
</IfModule>
        <IfModule mod_dav.c>
                DAVLockDB "/private/var/run/davlocks/.davlock249"
                DAVMinTimeout 600
        </IfModule>
<Directory "/Library/WebServer/Documents/mydomain">
  Options All Includes +MultiViews +ExecCGI -Indexes
  AllowOverride None
        <IfModule mod_dav.c>
                DAV On
        </IfModule>
</Directory>

<Directory "/Library/WebServer/Documents/mydomain">
  AuthName "mydomain.net"
  AuthType Basic
        <Limit PUT DELETE PROPFIND PROPPATCH MKCOL COPY MOVE LOCK UNLOCK>
                Require no-user
        </Limit>
</Directory>
</VirtualHost>

 


I have read and tried so much, I am clueless right now. Any help will greatly be appreciated.
 Quote

Status: Banned

machinari

Forum User
Full Member
Registered: 03/22/04
Posts: 1512
have you checked these settings?
Text Formatted Code
// you shouldn't need to edit the following
$_CONF['layout_url']        = $_CONF['site_url'] . '/layout/' . $_CONF['theme'];
$_CONF['path_themes']       = $_CONF['path_html'] . 'layout/';
$_CONF['path_layout']       = $_CONF['path_themes'] . $_CONF['theme'] . '/';

 
 Quote

Frlitz

Anonymous
They were the same as original settings.
 Quote

Status: offline

dewdoo

Forum User
Chatty
Registered: 01/03/04
Posts: 65
Well this is my OS X Server Install of geeklog. Hopefully this will help you out.

Text Formatted Code
// This should point to the directory where your config.php file resides.
$_CONF['path']            = '/Library/WebServer/'; // should end in a slash

// You only need to change this if you moved or renamed the public_html
// directory. In that case, you should specify the complete path to the
// directory (i.e. without the $_CONF['path']) like this:
// $_CONF['path_html']      = '/path/to/your/public_html/';
$_CONF['path_html']         = $_CONF['path'] . 'Documents/';
 

and
Text Formatted Code
// Make sure this is the correct URL to your site, i.e. to where Geeklog's
// index.php file resides (no trailing slash).
$_CONF['site_url']          = 'http://kents.mine.nu:8080';

 
 Quote

Frlitz

Anonymous
If I change site_url = http://mydomain.net:16080, no theme will appear. If I ln -s layout/professional professional in /Library/WebServer/Documents/mydomain/ the index, calendar, and search pages are rendered with the theme, again everything else i.e. forum, and admin block are without theme.

I have turned on verbose in lib-sessions, and lib-common and there is nothing in the error.log that is revealing.

Can you compare your vhost info to the vhost information I provided?

Thanks for reply.
 Quote

Status: offline

dewdoo

Forum User
Chatty
Registered: 01/03/04
Posts: 65
Are you using OS X Server or Client? I believe ur problem if your using OS X Server, is to try turning off performance cache 16080. In ur Server admin go to Web click on Sites tab. Then choose in the box below you domain name and click on the pencil to edit. In the general tab my Web Folder is located in /Library/WebServer/Documents. Then choose options tab and turn off Performance cache then save.

On client version I am not sure Sad I believe it is a path issue. I had the same problem about 3 years ago when installing geeklog. I used the forums at http://www.macosxhints.com to install geeklog. Here is the link. Hope this helps.... Without me not knowing how your file structure is, I am at a lost. Maybe you can contact me at samuelATkents.mine.nu and we can get you up and running correctly.
 Quote

Frlitz

Anonymous
I can describe further what I know to be occurring with the themes, but I do not yet know the answer for resolution.

When all session cookies have been removed and I do NOT log in, ALL pages are displayed as I navigate the site with the site theme as expected.

But, as soon as, I log in, the forum index page is rendered without the site theme. So, it is certainly NOT a path issue per se, the described behavior suggests that somehow this issue is related to session cookies.

How do I troubleshoot this? Is there something that I can change in the SESSION SETTINGS within config.php to correct this behavior?

Thanks for all replies
 Quote

Status: offline

dewdoo

Forum User
Chatty
Registered: 01/03/04
Posts: 65
seems to me u didnt copy the style.css from the forum to your theme style.css. Just guessing here....
 Quote

Status: offline

Frlitz

Forum User
Junior
Registered: 01/28/04
Posts: 15
Update: I have discovered that the behavior that I have been describing occurs when a value other than 'NULL' is in the geeklog table: gl_users.theme.

The value in gl_users.theme was updated when I changed user layout perferences from the site default theme 'professional' to 'klear_blue'. At this point, this is when complaints appeared in httpd/error_log and the GET in access_log becomes: "GET /professional/style.css instead of: "GET /layout/professional/style.css. (This is when I previous linked layout/theme at DocumentRoot to see the user pref theme when not logged in. )

Now that I know what is occuring, How do I solve it?

 Quote

All times are EST. The time is now 09:13 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content