Welcome to Geeklog, Anonymous Wednesday, June 19 2024 @ 10:34 am EDT

Geeklog Forums

New User Registration - no emails sent


Del

Anonymous
caffeinated
when I submit new user information. Geeklog doesn't email the information to the email that was provided.

I am using version 1.3.9sr2

what gives?
 Quote

Del

Anonymous
I have set the variable to 'smtp' in config.php and filled out the relevant usern/password stuff with the correct information... no emails are sent out

I then switched it to 'mail' and still no luck



---
also, is there a function in GL that allows users to have their passwords re-emailed to them in case they forgot it?
 Quote

Del

Anonymous
here is what my error log says:

[pear_error: message="Validation failed for "OntarioEmergency.ca "" code=0 mode=return level=notice prefix="" info=""]
Tue May 17 08:37:13 2005 - Error, invalid username: Dude
Tue May 17 08:37:35 2005 - [pear_error: message="Validation failed for "OntarioEmergency.ca "" code=0 mode=return level=notice prefix="" info=""]
Tue May 17 08:38:55 2005 - Error, invalid username: dsf
Tue May 17 08:39:22 2005 - [pear_error: message="Validation failed for "OntarioEmergency.ca "" code=0 mode=return level=notice prefix="" info=""]

Why is it giving me a validation error? the username, email and passwords are all correct.. so is the smtp mail server URL

the funny thing is that there is a user named "Dude" in my gl_users table.. I dont know why it says it is an invalid username

by the way, myemail@myemail.com is not what it really says.. I edited that out .. it actually says my real email address which is working perfectly fine
 Quote

Status: offline

knuff

Forum User
Full Member
Registered: 12/17/04
Posts: 340
Location:Sweden
Have a look here

In addition, you should use the latest stable release which is 1.3.11

Best Regards,
Boris
Vanrillaer.com - our Family Portal
 Quote

Del

Anonymous
here is the code for my site_name:

$_CONF['site_name'] = 'OntarioEmergency';
$_CONF['site_slogan'] = 'More Beds Less Waits';


no illegal characters in there that I can see..

still doesn't email information out to users!!!

I cant launch a website that doesnt email passwords for new user accounts! argh!!!
 Quote

Status: Banned

machinari

Forum User
Full Member
Registered: 03/22/04
Posts: 1512
Quote by Del:I then switched it to 'mail' and still no luck
have your tried 'sendmail'? ...and for your smtp host, some people have used smtp.www.example.com rather than smtp.example.com--see the difference? I dunno if that actually makes a difference...

Quote by Del:also, is there a function in GL that allows users to have their passwords re-emailed to them in case they forgot it?
yes. just go to, for example, http://medsim.net/users.php and you'll see a link leading to the forgotten password retrieval form--or just go to http://medsim.net/users.php?mode=getpassword

btw, feel free to delete my two usernames (testusername and deleteme) from your site. was just testing.

Also, are you using the CUSTOM_mail() function? if you are not sure, then you're probably not using it. If you are, that may be the prob. That's about as far as I can get without getting into the pear stuff.
 Quote

LWBS

Anonymous
I have tried sendmail, still doesnt work

I have tried smtp.www.domainname.com, still doesnt work

I am not using the custom_mail function

I do not know what to do

I have contacted my hosting service and they say everything is fine on their end yet my error log says different

PLEASE HELP!!!!!
 Quote

Status: offline

ronack

Forum User
Full Member
Registered: 05/27/03
Posts: 612
Does Admin get an email notification that someone has registered. I know when I had a problem sending out emails it was because I didn't set up the right email address for Admin

 Quote

wazimm

Anonymous
I have the same problem too... and I've tried everything.
-------------------------------------------------------------------------------

I just checked my error log and it says " [pear_error: message="unable to connect to smtp server mail.protgp.com:25" code=0 mode=return level=notice prefix="" info=""]


I'm using GL version=1.3.11
 Quote

Status: offline

wazimm

Forum User
Newbie
Registered: 05/25/05
Posts: 1
Fri May 20 04:52:41 2005 - Working on username=imakool2000, fullname=imakool2000, and email=imakool2000@yahoo.com
Fri May 20 04:52:41 2005 - [pear_error: message="sendmail [/usr/bin/sendmail] is not a valid file" code=0 mode=return level=notice prefix="" info=""]
Fri May 20 04:52:41 2005 - Account for imakool2000 created successfully
Fri May 20 04:52:41 2005 - Working on username=tayo2001ng, fullname=tayo2001ng, and email=tayo2001ng@hotmail.com
Fri May 20 04:52:42 2005 - [pear_error: message="sendmail [/usr/bin/sendmail] is not a valid file" code=0 mode=return level=notice prefix="" info=""]
Fri May 20 04:52:42 2005 - Account for tayo2001ng created successfully
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by wazimm: I just checked my error log and it says " [pear_error: message="unable to connect to smtp server mail.protgp.com:25" code=0 mode=return level=notice prefix="" info=""]

So the information to connect to your SMTP server is not correct (you may need to use authentication, for example).

If in doubt, ask your ISP. If they insist on "SMTP after POP", for example, you will not be able to use that SMTP server.

bye, Dirk
 Quote

richking

Anonymous
I seem to be having issues with all email configs:

Tue May 31 18:00:57 2005 - [pear_error: message="mail() returned failure" code=0 mode=return level=notice prefix="" info=""]

and

Tue May 31 23:23:10 2005 - [pear_error: message="sendmail [/usr/sbin/sendmail] is not a valid file" code=0 mode=return level=notice prefix="" info=""]

finally..

Tue May 31 23:30:53 2005 - [pear_error: message="unable to connect to smtp server smtp.isp.com:25" code=0 mode=return level=notice prefix="" info=""]

OpenBSD 3.7 with:
apache-1.3.29
mysql-server-4.0.23p1
php4-core-4.3.11
php4-extensions-4.3.11
php4-mysql-4.3.11
php4-pear-4.3.11
geeklog-1.3.11

 Quote

All times are EDT. The time is now 10:34 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content