Welcome to Geeklog Monday, December 06 2021 @ 01:52 am EST

Geeklog Forums

A MAJOR Poll Problem

Page navigation


Status: offline

samstone

Forum User
Full Member
Registered: 29/09/02
Posts: 820
I have reported similar problem previously here.

I am interested in the solution also.

Thanks,

Sam
 Quote

trohko

Anonymous
excited
Nope. No template files were edited.
I even started to compare this version of plugin with older ones (since polls moved out of geeklog core).
I found that polls plugin v1.1.0 of Geeklog v1.4.1 release works just fine. So I took that version and put it into geeklog v1.5 . It still worked just fine! Then, I switched back to original version (v2.0.1), the one that ships with geeklog v1.5. I tried to set up some parameters for poll plugin and found a SOLUTION! 8)

My webhosting server is uses the Suhosin extension for PHP. And this extension is limiting the number of variables, that pass through HTTP requests. If poll plugin is set to accept 10 options for 10 question in a single poll, that is 100 fields + options + some more variables , that need to pass through PHP server / Suhosin extension. In cases like that this suhosin quietly truncates fields to its limit; that's why field "mode" and some others were lost during POST action.

How to check for Suhosin limit in action: create a test.php file in your public directory and insert this line:
PHP Formatted Code
<?php phpinfo();?>

Somewhere in that long list, there should be a section like:

suhosin.get.max_vars 100 100
or
suhosin.post.max_vars 200 200
or
suhosin.request.max_vars 200 200

Based on testing: values 6-questions & 10-options works for me, but you should try your own server for it's limits.

Feels like .... marvelous! Big Grin
 Quote

Page navigation

All times are EST. The time is now 01:52 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content