Welcome to Geeklog Saturday, March 24 2018 @ 09:43 pm EDT


I have made my own blocks with my own links. When I click on the link, it goes to the link, but its like a new page, it doesnt open in the normal center area of geeklog. Does that make sense? If not, you can see what I mean, http://red-roote.com, click on "Hours" under the 1st block called information.

Any help would be GREATLY appreciated, besides changing the theme, this is all I need to figure out! Thanks

Status: offline


Forum User
Full Member
Registered: 05/08/2003
Posts: 969
Location:The Netherlands, where else?
The normal links should be like:


for topic related articles or


for static pages (if you don't use the URL rewrite option)

You're linking to non excisting pages which are not part of the system. I suggest you make static pages for the items shown in your menu and then make the appropiate links to them.
Dutch Geeklog sites about camping/hiking: www.kampeerzaken.nl | www.campersite.nl | www.caravans.nl | www.caravans.net


Maybe this will help. Heres what I have typed in my block text:

PHP Formatted Code
<tr><td width="100%" class="block-info-left">
<a href="http://red-roote.com/hours">Hours</a> <br>

Status: offline


Forum User
Full Member
Registered: 17/12/2004
Posts: 340

Beewee is right.

The reason why it opens a new page is because hours.php is not part of Geeklog and what you want to do is create a
static page and link to that.

That way it will be part of GL and have the correct layout and such.

Best Regards,

Vanrillaer.com - our Family Portal

All times are EDT. The time is now 09:43 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content