Welcome to Geeklog, Anonymous Friday, June 14 2024 @ 10:54 am EDT

Geeklog Forums

Adding A Japanese Character In Date/Time


Status: offline

Arcanum

Forum User
Junior
Registered: 11/05/04
Posts: 26
Location:Hokkaido, Japan
I have a really small problem I was wondering if someone could help me with. I'm running the Japanese translation of Geeklog for a client's site (you can see it at www.toyokoroedu.com) and I've got everything just running perfectly. But there is something I noticed that is missing from the Japanese translation.

In English we can just write the date as 3/23/05, 23 March 2005, or March 23, 2005 and so on. In Japanese, there is always a kanji character that goes after the month and after the day. I noticed in the Japanese translation that the kanji after the month is there, but the kanji after the day is not. You can see what I'm talking about by going to the site and looking at the date in the top left. It's correctly displaying the kanji after 3 for March, but there is no kanji being displayed for the day. So it just looks like this: Day (Monday, Tuesday, etc.) in kanji, numerical month followed by kanji, numerical day and numerical year. If your browser reads Japanese, it looks like this: 水曜日, 3月 23 2005.

I want to have the kanji for day come after the numerical day is displayed, so it would look like this: 23日 instead of just showing a 23. So the entire date would be displayed like this: 水曜日, 3月 23日 2005. I want to add that kanji in there, but I'm not sure where to add it. I checked the language file, but I didn't see it in there. Does anybody know where I would add that kanji?

I know it's a really small problem, but it would be cool if I could get it fixed. Thanks.

 Quote

tokyoahead

Anonymous
When I switch to the japanese language, my date does not change at all...
it stays english. is it a system setting? or a config.php?
 Quote

Status: offline

Arcanum

Forum User
Junior
Registered: 11/05/04
Posts: 26
Location:Hokkaido, Japan
I had a similar problem before and it turned out that I just didn't have the right code for the Japanese locale in the config.php. Set the following stuff in the locale in config.php up like this and you shouldn't have any problems:

$_CONF['language'] = 'japanese';
$_CONF['locale'] = 'ja_JP.eucJP';
$_CONF['default_charset'] = 'ja_JP.eucJP';

Hope that helped. Also, if you ever figure out how to add in the kanji for day after the numerical date, let me know. Thanks.

 Quote

All times are EDT. The time is now 10:54 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content