Welcome to Geeklog Thursday, November 23 2017 @ 11:53 am EST


Status: offline

trenchteam

Forum User
Regular Poster
Registered: 08/06/2004
Posts: 89
Checked my error log and it says I can access my database due to locked table???

Status: offline

trenchteam

Forum User
Regular Poster
Registered: 08/06/2004
Posts: 89
Okay, I found it. Heres the ERROR. No one can comment in my BLOG. Heres the error in the log.
PHP Formatted Code

*** dummy entry ***
1/1/2005 7:14:00 PM - [pear_error: message="mail() returned failure" code=0 mode=return level=notice prefix="" info=""]
1/2/2005 11:02:45 AM - 1044: Access denied for user: 'trench@%' to database 'xxx'. SQL in question: LOCK TABLES gl_comments WRITE
1/2/2005 8:31:05 PM - 1044: Access denied for user: 'trench@%' to database 'xxx'. SQL in question: LOCK TABLES gl_comments WRITE
1/2/2005 9:19:00 PM - 1044: Access denied for user: 'trench@%' to database 'xxx'. SQL in question: LOCK TABLES gl_comments WRITE


 


PHP Formatted Code
*** dummy entry ***
1/1/2005 7:14:00 PM - [pear_error: message="mail() returned failure" code=0 mode=return level=notice prefix="" info=""]
1/2/2005 11:02:45 AM - 1044: Access denied for user: 'trench@%' to database 'xxx'. SQL in question: LOCK TABLES gl_comments WRITE
1/2/2005 8:31:05 PM - 1044: Access denied for user: 'trench@%' to database 'xxx'. SQL in question: LOCK TABLES gl_comments WRITE
1/2/2005 9:19:00 PM - 1044: Access denied for user: 'trench@%' to database 'xxx'. SQL in question: LOCK TABLES gl_comments WRITE
1/3/2005 12:55:47 AM - 1044: Access denied for user: 'trench@%' to database 'xxx'. SQL in question: LOCK TABLES gl_comments WRITE
1/3/2005 1:10:07 AM - 1044: Access denied for user: 'trench@%' to database 'xxx'. SQL in question: LOCK TABLES gl_comments WRITE
1/3/2005 1:30:08 AM - 1044: Access denied for user: 'trench@%' to database 'xxx'. SQL in question: LOCK TABLES gl_comments WRITE
1/3/2005 2:25:31 AM - 1044: Access denied for user: 'trench@%' to database 'xxx'. SQL in question: LOCK TABLES gl_comments WRITE

 


I was trying to comment myself, since others told me they couldnt comment. Not sure how to fix this problem.


tokyoahead

Anonymous
Check your permissions with phpMyAdmin if you are allowed to do LOCK

try to execute the command manually with phpMyAdmin and check the error you get (if any)

Status: offline

trenchteam

Forum User
Regular Poster
Registered: 08/06/2004
Posts: 89
allowed to do lock? Im not understanding?

What do you mean by executing the command?

BTW, my comments were working prior to the upgrade from 1.3.10 to the newest one. Not sure what happened.

I noticed that the file in the SQL folder for the upgrade from 1.3.10 to 1.3.11 includes this:

PHP Formatted Code
<?php

// bugfix: allow up to 40 characters for the story ID
$_SQL[] = "ALTER TABLE {$_TABLES['comments']} CHANGE sid sid varchar(40) NOT NULL default ''";

?>

 



It seems to have to do with my comments? Im wondering if something may have went wrong during the upgrade? Steps I can take? Possibly reload the COMMENTS Table? How can I execute this? I was thinking that I could drop the COMMENTS table, then reload it? Can someone tell me how I can do this???

This is all coming out of the top on the head based on the error and the upgrade I made. Sorry, Im ranting! Just disappointed that the comments are not working.

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/2002
Posts: 13073
Location:Stuttgart, Germany
As usual, a quick search would have brought up the answer. See the latter half of this thread for example.

The FAQ also has some information (although only as a side note - I guess we need a separate entry for this ...).

bye, Dirk

Status: offline

trenchteam

Forum User
Regular Poster
Registered: 08/06/2004
Posts: 89
I tried a seach and came up with nothing. I actually searched a couple days before asking this question. Guess Im not a good searcher! anyways, thanks Dirk. I guess i have to solve this with my provider.

Status: offline

trenchteam

Forum User
Regular Poster
Registered: 08/06/2004
Posts: 89
My hosting service (godaddy) said they can't grant me those permissions because it is a global flag. Why would comments in 1.3.9 work but fail in version 1.3.10rc3?

http://www.geeklog.net/forum/viewtopic.php?showtopic=43804

jeez, this sux if I've lost my comment function.


Seems like Im in the same boat as this poor guy. My hosting service Webhost4life said they have to check with a manager before doing this change due to a GLOBAL FLAG. If they cant do this for me, is there any way around it? I dont want to change from Geeklog because of this, but comments are the lifeline of my site, if they cant change those permissions, I may have no choice.

Status: offline

trenchteam

Forum User
Regular Poster
Registered: 08/06/2004
Posts: 89
Grrr. Didnt work. Gonna make the switch I guess to wordpress. Dang. Lots of stories to move!

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/2002
Posts: 13073
Location:Stuttgart, Germany
I would be interested in the response from your hosting service about why exactly they can't grant you that permission.

Obivously, if this becomes a widespread problem, we will have to do something about it.

But for now, I fail to see how the permission to lock tables is any different from the other MySQL permissions, such as to drop, create, or modify tables ...

You could comment out the SQL queries that lock/unlock the comments table in comments.php, but you'll risk a corruption of that table when two users are posting a comment at the same time.

bye, Dirk

Status: offline

enigmah

Forum User
Chatty
Registered: 22/07/2002
Posts: 50
I am also having the same problem. I am using Ipowerweb.com

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/2002
Posts: 13073
Location:Stuttgart, Germany
Quote by enigmah: I am also having the same problem. I am using Ipowerweb.com

And what was their explanation why they can't give you that permission?

bye, Dirk

Status: offline

enigmah

Forum User
Chatty
Registered: 22/07/2002
Posts: 50
They were able to give mysql users fully 'Lock Tables' privileges, now the commenting works..

Driadan

Anonymous
I have the same problem, I use the services from servage.net and the response was:
You are fully able to update tables without first locking them. If you would like a transaction safe enviroment we recommend using the InnoDB tables type.


Since I don't know anything of databases, i was unnable to response to this.

I hope, there can be a workarround to this, I really like geeklog system. But, if I can't solve it, i'm afraid i'll have to change to another software

Driadan

P.S.:btw does anyone know what is a InnoDB table type?

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/2002
Posts: 13073
Location:Stuttgart, Germany
Quote by Driadan: You are fully able to update tables without first locking them. If you would like a transaction safe enviroment we recommend using the InnoDB tables type.

Well, that doesn't explain why they're not able to give you table lock permissons ...

Using InnoDB tables isn't an option, as that would raise the minimum requirements to MySQL 4.x.

Quote by Driadan: P.S.:btw does anyone know what is a InnoDB table type?

MySQL supports several types of tables. Geeklog currently uses MyISAM tables. InnoDB tables have additional features, but are not available everywhere (and they have disadvantages in other areas, e.g. it's difficult to create a consistent backup).

bye, Dirk

Driadan

Anonymous
thanks for the info, now I'll ask them again...
As soon as I receive an answer i'll post here

Driadan

DeCEiVeR

Anonymous
Quote by Driadan: thanks for the info, now I'll ask them again...
As soon as I receive an answer i'll post here

Driadan


Well its been a while since I've tried to do anything about this but my hosting said they couldn't change it, thought they said it was a global flag and not just something on my account.

If anyone gets any headway let me know!!

DeCEiVeR

Anonymous
Quote by Dirk: I would be interested in the response from your hosting service about why exactly they can't grant you that permission.

Obivously, if this becomes a widespread problem, we will have to do something about it.

But for now, I fail to see how the permission to lock tables is any different from the other MySQL permissions, such as to drop, create, or modify tables ...

You could comment out the SQL queries that lock/unlock the comments table in comments.php, but you'll risk a corruption of that table when two users are posting a comment at the same time.

bye, Dirk


Well I commented out ""//DB_query("LOCK TABLES {$_TABLES['comments']} WRITE");"" and ""//DB_query('UNLOCK TABLES');"" in the comment.php file to get aroaund this problem for now, but it looks like after talking to about 3 different people at my hosting company that i'm not going to be able to get them to do anything about this. So if a fix becomes available please post.

Status: offline

Turias

Forum User
Full Member
Registered: 20/10/2003
Posts: 807
Have you thought about switching providers? If they can't do something as simple as give your mySQL user LOCK privs, I would be worried about what else they can't do.

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/2002
Posts: 13073
Location:Stuttgart, Germany
I have to agree with Turias. This talk about a "global flag" doesn't seem to make sense. As I said above, all that should be required is to grant you one more permission (that to lock tables). Surely that shouldn't be a problem?

Or if it is, I'd like to hear a more detailed explanation, please.

bye, Dirk

Driadan

Anonymous
well, they answered this:

The problem is that newer versions of mysql does not allow users to lock tables when using myisam tables. As we do not want to want to downgrade we will need to find another solution - are you sure you need to lock a table (and why would you do that?).


regards,

Driadan

All times are EST. The time is now 11:53 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content