Welcome to Geeklog, Anonymous Thursday, December 08 2022 @ 01:45 am EST

Geeklog Forums

Easyfile file management plugin

Page navigation


Status: offline

Kelvin

Forum User
Chatty
Registered: 10/08/02
Posts: 50
Yes, I'm aware of this bug. I did some restructuring of the code for 0.7.2 which inadvertently caused this bug. Sorry about that, I have it fixed in my local tree which will be released as 0.7.3 this week.

The problem was that I placed the check for "read access to root folder" in functions.inc which causes that particular code to be executed on ALL pages on the site.

Once again: I'm really sorry about this.
 Quote

Status: offline

casper

Forum User
Full Member
Registered: 02/11/04
Posts: 142
Location:Skien, Norway
Why be sorry, you know about it and Im waiting for next release Very Happy
You've made a great plugin, and it suits my needs perfectly!
Good work!
 Quote

Status: offline

casper

Forum User
Full Member
Registered: 02/11/04
Posts: 142
Location:Skien, Norway
Have you made the release yet?

And have you fixed this bug reported at Blaines site?
Easyfile screws up the forum Giving it a try
http://www.portalparts.com/forum/viewtopic.php?forum=2&showtopic=4669
 Quote

Status: offline

Kelvin

Forum User
Chatty
Registered: 10/08/02
Posts: 50
Quote by casper: Have you made the release yet?

And have you fixed this bug reported at Blaines site?
Easyfile screws up the forum Giving it a try
http://www.portalparts.com/forum/viewtopic.php?forum=2&showtopic=4669


I promised 0.7.3 this week, and I have now released (with 90 minutes to spare) Very Happy . The 0.7.2 bug with the forum is indeed fixed. Thanks for pointing it out to me.

Apologies to all forum users for this. I don't run the forum myself, so I didn't notice this bug.
 Quote

Status: offline

casper

Forum User
Full Member
Registered: 02/11/04
Posts: 142
Location:Skien, Norway
Looking good Kelvin!
Took it for a testrun now, and both bugs I reported are fixed Big Celebration
 Quote

Status: offline

BennyB

Forum User
Newbie
Registered: 03/29/05
Posts: 3
awake
Snygg kod!

Allright, back to swinglish:

Is there a way of making it display only the files that are in the folder I am looking into, and none of the files that are in the subfolders?

It would be useful for me. I think the previous version (1.7.2) did that, but I could be wrong.

/BB


 Quote

Status: offline

Kelvin

Forum User
Chatty
Registered: 10/08/02
Posts: 50
Quote by BennyB:Is there a way of making it display only the files that are in the folder I am looking into, and none of the files that are in the subfolders?

With the exception of the root folder, only files in the current folder are displayed. Are you getting a different behaviour?
 Quote

Status: offline

BennyB

Forum User
Newbie
Registered: 03/29/05
Posts: 3
Oh, so that's what it is doing.

OK, can I stop it from showing any files in public folders when I am in the root?

So that it shows only folders when the user is in the root?
 Quote

Status: offline

Kelvin

Forum User
Chatty
Registered: 10/08/02
Posts: 50
Quote by BennyB: OK, can I stop it from showing any files in public folders when I am in the root?

So that it shows only folders when the user is in the root?

No, not without hacking the code. Should be an easy hack though; look in /easyfile/index.php

BTW, this has been the default behaviour in all versions of easyfile (modelled after the behaviour of filemgmt)
 Quote

Status: offline

BennyB

Forum User
Newbie
Registered: 03/29/05
Posts: 3
okidoki

will give it a shot

thanks for a good plugin!
 Quote

Status: offline

e-crins

Forum User
Newbie
Registered: 08/11/05
Posts: 6
I hope I'm in the right place to ask this..

I wnated to install easyfile today.
Followed the instructions, copied allt the files to their designated places.
created a folder outside the html tree for files to be managed by easyfile.

logged in as admin, clicked 'install' next to 'easy file' on the plugin page and got a white screen with 'done' at the bottom of my browser (firefox)
In the errorlog all seems to be well. A lot of 'succes'-es.
Untill here:

Wed Sep 14 13:52:37 2005 - Adding easyfile.admin feature
Wed Sep 14 13:52:37 2005 - Success
Wed Sep 14 13:52:37 2005 - Adding easyfile.admin feature to admin group


any hints on what it is I am doing wrong?
 Quote

Benta

Anonymous
Quote by e-crins: I hope I'm in the right place to ask this..

I wnated to install easyfile today.
Followed the instructions, copied allt the files to their designated places.
created a folder outside the html tree for files to be managed by easyfile.

logged in as admin, clicked 'install' next to 'easy file' on the plugin page and got a white screen with 'done' at the bottom of my browser (firefox)
In the errorlog all seems to be well. A lot of 'succes'-es.
Untill here:

Wed Sep 14 13:52:37 2005 - Adding easyfile.admin feature
Wed Sep 14 13:52:37 2005 - Success
Wed Sep 14 13:52:37 2005 - Adding easyfile.admin feature to admin group


any hints on what it is I am doing wrong?


Not sure if there is anything wrong. Does the plugin work?
 Quote

Status: offline

e-crins

Forum User
Newbie
Registered: 08/11/05
Posts: 6
I can't find any changes on my geeklog page that say that it does work.

and if I log in as admin, go to the plugin page, easy file is still in the 'new plugins' list...

where should the plugin appear?

if I go to my site: http://www.nijmeegseluchtvaartclub.nl/easyfile/index.php it states that the plugin is curently disabled.

any suggestions?

p.s. in the config.php of easyfile I set
$_EF_CONF['basedir'] ="l/sitelog/download/";
the directory exists and is empty.

 Quote

Status: offline

e-crins

Forum User
Newbie
Registered: 08/11/05
Posts: 6
tried the filemgmt plugin also.
Same deal.
when I hit 'install' in the 'new plugins' list I get a white window in Firefox saying 'done' in hte bottom left corner.
So it's probably not the plugin that's wrong but something I do or some setting on the server side.
All the files asociated with the plugin have the property 700
read write modify by owner.
Maybe this is wrong?
 Quote

Benta

Anonymous
Quote by e-crins: t
All the files asociated with the plugin have the property 700
read write modify by owner.
Maybe this is wrong?


Oh, that would be a problem. Maybe the program that you use to upload sets strange rights to files.

You need to give the server access to the files and to give it right to write in the folder where it keeps the files

I think you can 755 everything, but need to give 777 to the storage folder of easyfile.
 Quote

Status: offline

e-crins

Forum User
Newbie
Registered: 08/11/05
Posts: 6
I'll try this as soon as I get home from work.

Or maybe even sooner.. Wink
thank you for the hints.
 Quote

Status: offline

e-crins

Forum User
Newbie
Registered: 08/11/05
Posts: 6
p.s.
Can I try to install many times?
Doesn't this create just as many new tables in my GL database?
Or does it simply overwrite existing tables/recreate them, just so that I don't overdo things.
 Quote

Status: offline

samstone

Forum User
Full Member
Registered: 09/29/02
Posts: 820
It will not create additional tables. In fact, it there is a table already there, the installation won't even go through, telling you that the table already exist. If the previous installation did create the table, you have to uninstall it, or manually remove the table.

Sam
 Quote

Status: offline

e-crins

Forum User
Newbie
Registered: 08/11/05
Posts: 6
no installer telling me that the tables already exist.
Nothing at all realy, just the blank screen.
The error log keeps givving 'succes' for creating tables, but it still halts when it wants to add easyfile.admin features to admin group.

Fri Sep 16 11:28:03 2005 - Attempting to create easyfile admin group
Fri Sep 16 11:28:03 2005 - ...success
Fri Sep 16 11:28:03 2005 - About to save group_id to vars table for use during uninstall
Fri Sep 16 11:28:03 2005 - ...success
Fri Sep 16 11:28:03 2005 - Inserting default data into folders table
Fri Sep 16 11:28:03 2005 - Success - inserting data into folders table
Fri Sep 16 11:28:03 2005 - Adding easyfile.admin feature
Fri Sep 16 11:28:03 2005 - Success
Fri Sep 16 11:28:03 2005 - Adding easyfile.admin feature to admin group

Was it wrong of me to unpack files on local disc and then upload the lot?


Using filezilla, I don't seem to be able to unpack the file when it's on the site's server.
 Quote

Status: offline

samstone

Forum User
Full Member
Registered: 09/29/02
Posts: 820
Was it wrong of me to unpack files on local disc and then upload the lot?


Unpacking files is not wrong, but it depents on how you unpack it. I use WinRAR and have no problem. I had problem with using Winzip in the past.

Sam
 Quote

Page navigation

All times are EST. The time is now 01:45 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content