Welcome to Geeklog, Anonymous Monday, December 05 2022 @ 07:51 pm EST

Geeklog Forums

INTEGRATION WITH 4IMAGES


Tina Peters

Anonymous
hopeful
THE LATEST VERSIONS OF BOTH [GL + 4IMAGES ] WHEN FRESHLY INSTALLED TOGETHER WITH THE AVAILABLE INTEGRETI PACK **DOES NOT WORK**

I CANNOT MOVE ONTO ANY OTHER SYSTEM AS MY ATTACHMENT WITH GL FROM .37 IS TOO STRONG, NEITHER I HAVE THE PAYING CAPACITY TO BUY INTEGRATED SYSTEMS LIKE vbb+photopost+classifieds with unified login

THE GL AS WELL AS 4IMAGES COMMUNITY SEEMS TOTALLY UNRESPONSIVE TO THIS NEED WHILE OTHER CMS S APPARENTLY ARE WELL INTEGRATING OR HAVING THEIR OWN IMAGE GALLERY.

PLEASE BE KIND TO HELP OR AT LEAST INSTRUCT WHAT CHANGES TO THE CURRENT INTEGRETI PACKAGAE TO BE MADE
 Quote

Status: offline

Blaine

Forum User
Moderator
Registered: 07/16/02
Posts: 1232
Location:Canada
ALL CAPS comes across as yelling and I don't like to be yelled at

It really does not motivate me to take more personal time to install and retest the integration when I have no use for it right now. I know I could certainly improve it at the same time but well that may be 4+ hours of work.

There has to be others that have a need and want a weekend project but then again - not sure if they like be yelled at or bullied either
Geeklog components by PortalParts -- www.portalparts.com
 Quote

Status: offline

ScurvyDawg

Forum User
Full Member
Registered: 11/06/02
Posts: 523
You may want to try over at www.squatty.com I think he did the initail integration didn't he?

He is not very active right now however.

 Quote

Status: offline

Blaine

Forum User
Moderator
Registered: 07/16/02
Posts: 1232
Location:Canada
Quote by ScurvyDawg: You may want to try over at www.squatty.com I think he did the initail integration didn't he?

I believe Danny helped on it but it was primarily Matthew Dewyer and I - but that was about 18 mths ago and GL 1.3.7. I suspect that the manual integration scripts could still be used today to make it work.

GL 1.3.10 now has new user admin API's that could be used to now create an integration plugin for 4images that would be nicer and not require any file hacks.

Maybe someone will step up that has a need and some time. I have too many projects now.
Geeklog components by PortalParts -- www.portalparts.com
 Quote

Status: offline

ScurvyDawg

Forum User
Full Member
Registered: 11/06/02
Posts: 523
Sorry Blaine I was not aware.

 Quote

Tina Peters

Anonymous
ummm ....

sorry, Blaine, that was a locked caps lock .

now , any cms need to integrate a gallery , at least that is what seems from other cms-es and also from my need, and GL need to seriously re-think at it if it does not want to get static

it will be really helpful if some one could do this or just make in-build gallery with the next version

i guess GL at present is not blessed with sufficient number of developers who can afford some free time and labor as well , like some other cms es are doing and unfortunate for the very few users like us we do not have a community who can come up with updated plugins along with the development of updated versions of GL
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by Tina Peters: now , any cms need to integrate a gallery

How many do you need?
 Quote

Status: offline

jhk

Forum User
Chatty
Registered: 07/13/02
Posts: 57
nerdy
Tina,
I think you should go back and try the integration again. It worked for me with GL 1.3.9 and (as far as I recall) I didn't "fix" anything. The integration just calls for a steady hand and a reliable eye. Good hack by Blaine and Matthew.

If you are really curious to see how it works (or interested in U8 soccer), you can see the working integration at: AFK - Årgang 96 (in Danish).
 Quote

Status: offline

digitalfiasco

Forum User
Chatty
Registered: 10/20/04
Posts: 42
Quote by Tina Peters: now , any cms need to integrate a gallery , at least that is what seems from other cms-es and also from my need, and GL need to seriously re-think at it if it does not want to get static

it will be really helpful if some one could do this or just make in-build gallery with the next version


Just out of curiosity, what's wrong with using Gallery? The newest release integrates into Geeklog very well. If you're partial to 4Images and don't mind paying a fee for commercial use, then fine...but if you do mind, then stick with Gallery.

Joe
 Quote

Tina Peters

Anonymous
Hiya thanks all.

Gallery is too bloated for my purpose plus i badly need "send ecard" feature. also pm and other goodies are a plus with 4images. 4images can also be tested on my machine without the need of GD or such. Mine use is non-commercial and 4images is free for such purpose.

4images is now and Gl 4images1.7.1- and GL is geeklog-1.3.10rc2 - together they give "fatal error etc etc "
 Quote

Tina Peters

Anonymous
How many do you need?- Dirk


I sincerely apologize - I have been thru that faq. True you have already galleries available, I am biased with images as that meets my needs ( specifically "add to my favorites" and "send ecard" )

Sorry, really.

Still , any help with 4images integrati ( as Baline says its 4 hour work ) will be great help
 Quote

Tina Peters

Anonymous
once again, sorry

but has anyone tried the latest versions ?

geekary latest and GL do not get installed
gallery latest does not have automatic integration with GL 1.3.10rc2
4images latest with Gl latest give fatal error

BTW, what will be the feture loss if i revert back to GL .8 , more plugins work with that
( dont we have developers who have free time and mind to develope updated plugins ), with the previous versions i did have buggy calendar and i dont remember about comments system

will the final release of .10 be more friendly ? and when is that expected ? i know its difficult to have any deadline.
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by Tina Peters: gallery latest does not have automatic integration with GL 1.3.10rc2

I'm running a Geeklog site with Gallery integrated just fine. It was a fresh install of Geeklog from CVS just prior to the release of 1.3.10rc1 with Gallery 1.4.4pl1 and it worked out of the box. I doubt that any of the two has changed so much since then that it broke the integration (I did actually update Gallery to 1.4.4pl4 and it still works).

Quote by Tina Peters: will the final release of .10 be more friendly ?

I don't see how the current version is being "unfriendly" ...

Quote by Tina Peters: and when is that expected ?

All I can say for now is that there will at least be a 1.3.10rc3.

bye, Dirk
 Quote

Tina Peters

Anonymous
Hi Dirk,

Gl is the most friendly cms so far , being more friendly means more
in-packed plugins like spam x etc that can be installed or uninstalled at will and v e r y easily

its a fact - geekery and latest 4images do not work with latest GL , i guess Gallery is fine but they dont have the autointegration with the l a t e s t version.


was not cms es suppose to make life easy ? one can still use editors and build webpages and website, why cms - becoz they make things easy and integrated

while GL focusses on security, and other core php issues, at the lame users end easy plugins of standard stuffs namely forum, pm , gallery, classifieds will be blessed by many.



thnnxxx again.
 Quote

Tina Peters

Anonymous
BTW Gallery is now Gallery 2 FARVA
 Quote

Status: offline

digitalfiasco

Forum User
Chatty
Registered: 10/20/04
Posts: 42
Quote by Tina Peters: BTW Gallery is now Gallery 2 FARVA


I think you're getting ahead of yourself. First of all, Gallery 2 (Farva) is currently in alpha, certainly not anything you want in a production website. Also, the latest 4images version (1.7.1) is currently in beta.

Geeklog always comes thru...Just be patient.
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by Tina Peters: BTW Gallery is now Gallery 2 FARVA

No, it's not. If you go to the Gallery homepage, you'll see that the current version is 1.4.4pl4 (which integrates just fine with Geeklog). They even mention that a version 1.5 is in the works, so it looks like Gallery 2 is still some time away.

bye, Dirk
 Quote

Tina Peters

Anonymous
hiya, thanks

4images - the previous version ( not the beta ) gives fatal error with the latest GL


>> the current version is 1.4.4pl4
i did not say that is not the current version.
gallery site -
new3 line 4 at gallery site - "G2 is stable and reliable"

>> I think you're getting ahead of yourself

whats the harm if developers at GL are also upto date and advanced and does some playing too - the community at other cms es are also having other priorities in life and giving free labor, but this doeas not mean i shud be asked to move to those Sad

so life is not easy even at premises of cms es -
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by Tina Peters: gallery site -
new3 line 4 at gallery site - "G2 is stable and reliable"

Your forgot to quote the rest of that paragraph: "and is not yet ready for a production environment."


Quote by Tina Peters: whats the harm if developers at GL are also upto date and advanced and does some playing too - the community at other cms es are also having other priorities in life and giving free labor, but this doeas not mean i shud be asked to move to those Sad

so life is not easy even at premises of cms es -

Not sure what your point is in all this. At least 2 of the 4 existing gallery solutions are working (Gallery and MIG). The other 2 seem to need some work, but that's something the community can do.

Since you seem to be particularly interested in the 4images integration, why not help with that? If you can't help with coding, how about funding the development?

If there are any specific problems caused by Geeklog itself, the team will be happy to assist (as we have done in the past, including making specific changes to support certain plugins / extensions). But, as I said, at this point I don't see anything we can (or should) do ...

bye, Dirk
 Quote

geeklog-fan

Anonymous
sad
I installed 1.3.10 today, 4images is working (I guess because it was already installed on 1.3.9), but as soon as I do something to a user (delete, edit) or a new user registers I am seeing database errors..

I can't do it without 4images...

All these lines are gone in users.php, usersettings.php, user.php

DB_change($_TABLES['usercomment'],'commentlimit',$_CONF['comment_limit'],'uid',$uid);

DB_query("UPDATE {$_TABLES['userinfo']} SET pgpkey='" . $A["pgpkey"] . "',about='{$A["about"]}' WHERE uid={$_USER['uid']}");

DB_query("INSERT INTO {$_TABLES['userinfo']} (uid) VALUES ($uid)");

DB_query("UPDATE {$_TABLES['users']} SET username = '$username', fullname = '$fullname', passwd = '$passwd', email = '$email', homepage = '$homepage', photo = '$curphoto' WHERE uid = $uid");


I remember some of the old code was moved tot lib-user.php, but the code is gone there as well.. Neutral

some help would be much appreciated
 Quote

All times are EST. The time is now 07:51 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content