Welcome to Geeklog Monday, October 23 2017 @ 04:04 am EDT


Status: offline

vbgunz

Forum User
Full Member
Registered: 24/01/2003
Posts: 169
I am working on a template theme for future projects. It validates without trickery and is simple on almost all ends. It looks beautiful in Mozilla *but* IE is giving me one little problem which is really burning me up...

When I click on submissions, I am not certain what the problem is, but my right side div containers seem to expand a few pixels to much to the right beyond the border. Basically about, 15 to 20 pixels is under the border without a horizontal scrollbar... For some odd reason I just cannot get it to show up correctly whereas in Mozilla it shows up just fine...

I've been at this and perhaps it's the fact I am not too awesome at all at anything outside of tables If anyone has any bright ideas, I'd really love to hear them about now...

Thank you for your time!
Victor B. Gonzalez - http://aeonserv.com

Status: offline

wooge

Forum User
Junior
Registered: 27/12/2002
Posts: 17
*sigh* i run into wierdnesses like this all the time. If only the world used mozilla or safari, we'd be set

... any chance you have a URL or screenshots we can trouble shoot from? i'm a visual person

Status: offline

machinari

Forum User
Full Member
Registered: 22/03/2004
Posts: 1512
IE has bad habit of inserting margin space where margins are not specified. and if they are specified to something >0 then IE may double them. wierd.

check this doc for bugs and workarounds when dealing with IE.

hope that helps

Status: offline

obione

Forum User
Newbie
Registered: 07/04/2004
Posts: 8
yeap, IE as a lot of troubles with CSS. best solution would to consider puttin a bit of tables there. IE and CSS just don't mix together. just for pure curiosity do this: post a very long comment on the Xsilver theme, on the polls. then post another very long comment in reply to this comment. view the comments in nested form. the second comment will be chopped out in it's end in IE.

Status: offline

JohnVanVliet

Forum User
Full Member
Registered: 09/10/2003
Posts: 161
*sigh* i run into wierdnesses like this all the time. If only the world used mozilla


ooh yaa IE dose some odd stuff to theems

I GAVE UP ON TRIING TO PLEASE MICROSOFT
just look at mine ie kills the nice colors around the bouttons
Mozilla dose not
now i did give in and not use 32 bit.png 's only 24 bit ones

Status: offline

vbgunz

Forum User
Full Member
Registered: 24/01/2003
Posts: 169
wOOge, would you like I send you a copy of the entire theme so hopefully a bit of your wisdom could help solve this minor annoyance? This theme still has a long way to go but its starting out quite nicely...

At the moment I only need help with fixing the presentation in IE regarding the center tables e.g., click on submissions under admin login and you'll see how the tools in the center stretch beyond the right scroll bar...

News Flash! It seems even if I get the divs to all show up within the boundaries of the right scroll bar, they're all cut off by what seems to be or is better called an invisible mask... It seems an object, the same color of the background is hovering over and cutting off the right side edge of the content...

Thats my deal. I need some help and insight. Anyone interested please yell and w00ge, I'd definitely give you a copy so to check out.

Thanks a million to everyone for their time!
Victor B. Gonzalez - http://aeonserv.com

Status: offline

wooge

Forum User
Junior
Registered: 27/12/2002
Posts: 17
Hi Victor... well you could send me the theme - but i make no guarantees i can tame the IE beast...

If i figure out what the solution is i'll post it here, and e-mail back your files.

Status: offline

machinari

Forum User
Full Member
Registered: 22/03/2004
Posts: 1512
Quote by vbgunz: ... At the moment I only need help with fixing the presentation in IE regarding the center tables ... It seems even if I get the divs to all show up within the boundaries of the right scroll bar, they're all cut off by what seems to be or is better called an invisible mask... It seems an object, the same color of the background is hovering over and cutting off the right side edge of the content...


couple quick tips that may make your life easier, or not...

IE for windows interprets table width=100% as 100% of the display when it is set within a div, no matter if your div is acting properly with its width=100%. so, if your content table, inside a div, is next to your left blocks, your table will extend off the right of your display exactly the width of your left blocks or the remaining width of your display. does that make sense? your 100% is being pushed right by the left blocks. fix for this is to keep the div at 100% and set the table to width=inherit. now your table will be 100% of the div, not the display. if you tables are nested in tables, you wont have this problem.

another possiblity is that IE for windows has what is called the "box model bug." IE incorrectly includes padding, borders, and margins in the width value.

hope some of that helps...

Status: offline

vbgunz

Forum User
Full Member
Registered: 24/01/2003
Posts: 169
Sorry everyone for my late reply. I've been extremely busy on some offline stuff and have a few moments to spare. w00ge, you want a copy? where should I send it? I am already a member on Axonz, should I upload it there? Machinari, Thanks a million for your advice, I tried and failed. I am beginning to believe I probably uncovered a bug with IE . If you too would like a copy of the theme please let me know. Thanks to everyone for your time.


Victor B. Gonzalez - http://aeonserv.com

All times are EDT. The time is now 04:04 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content