Welcome to Geeklog, Anonymous Monday, May 27 2024 @ 02:41 pm EDT

Geeklog Forums

File Mgmnt


Michael Heber

Anonymous
I have installed the file manager, but when I click on the link to the filemgmnt admin it goes to the url "www.deckevolution.com/gl/admin/plugins/filemgmnt/index.php" It adds the admin path for some reason. The only way I can access the filemgmnt admin is by going to www.deckevolution.com/gl/plugins/filemgmnt/index.php

Does anyone know why it inserts the admin path?

Thanks,

Michael
 Quote

Status: Banned

machinari

Forum User
Full Member
Registered: 03/22/04
Posts: 1512
Quote by Michael Heber: ...when I click on the link to the filemgmnt admin ... it adds the admin path for some reason.
It's supposed to.
Quote by Michael Heber: ...The only way I can access the filemgmnt admin is by going to www.deckevolution.com/gl/plugins/filemgmnt/index.php
Does anyone know why it inserts the admin path?
Looks like you've place some files in the wrong dirs... You may want to recheck the install instructions. Make special note of step one.
 Quote

Michael Heber

Anonymous
I have looked at step 3.1, where should I create the directories?

www.deckevolution.com/gl

www.deckevolution.com/gl/plugins/filemgmt/

www.deckevolution.com/gl/filemgmt
 Quote

Status: Banned

machinari

Forum User
Full Member
Registered: 03/22/04
Posts: 1512
assuming that your geeklog doc root is www.deckevolution.com/gl/ then your dir structure according to step 4.1 should be:

www.deckevolution.com/gl/filemgmnt_data
www.deckevolution.com/gl/filemgmnt_data/files
www.deckevolution.com/gl/filemgmnt_data/files/tmp
www.deckevolution.com/gl/filemgmnt_data/snaps
www.deckevolution.com/gl/filemgmnt_data/snaps/tmp
www.deckevolution.com/gl/filemgmnt_data/category_snaps

and don't forget to set the proper permissions.

but you still have a problem.. ie, those dirs have nothing to do with your admin stuff. for that you must follow step 1 under New Installation and place the plugin files under their proper dirs.

your only other option is that you have installed gl into dirs that are not default. if so then you must adjust your plugin dirs to match. probably not that tho
 Quote

Michael Heber

Anonymous
I have got the files in the admin folder of my filemgmt plugin here:

www.deckevolution.com/gl/plugins/filemgmt

I have got the files in the public html directory of my filemgmt plugin here:

www.deckevolution.com/gl/filemgmt

Is this right?

And which file do I go to set the permissions?

Thanks,

Michael
 Quote

Status: Banned

machinari

Forum User
Full Member
Registered: 03/22/04
Posts: 1512
Quote by Michael Heber: I have got the files in the admin folder of my filemgmt plugin here:

www.deckevolution.com/gl/plugins/filemgmt

4.0 New Installation step 1.2
The three files in the admin directory under your new plugins/filemgmt folder need to be moved to deckevolution.com/gl/admin/plugins/filemgmt.

Quote by Michael Heber:I have got the files in the public html directory of my filemgmt plugin here:

www.deckevolution.com/gl/filemgmt

Is this right?

yes according to step 1.2

Quote by Michael Heber:And which file do I go to set the permissions?

Thanks,

Michael

assuming you use ftp, you must chmod the dirs and files listed under New Installation step 3.
from the install doc:
Text Formatted Code
3.2            Set directory ownership to that of your webserver on all module directories and files - including data directory.

eg: chown -R www:www filemgmt_data

Set permissions on directories and files to 754

Need to allow write permissions for Webuser to filemgmt_data directory
 

hope that helps
 Quote

Michael Heber

Anonymous
I have copied the files in the

www.deckevolution.com/gl/plugins/filemgt directory to the

www.deckevolution.com/gl/admin/plugins/filemgmt directory

But now I get this message


Warning: main(../../lib-common.php): failed to open stream: No such file or directory in /home/michael/public_html/gl/admin/plugins/filemgmt/index.php on line 31

Fatal error: main(): Failed opening required '../../lib-common.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/michael/public_html/gl/admin/plugins/filemgmt/index.php on line 31

Do you know what I am doing wrong?

Thanks,

Michael
 Quote

Status: Banned

machinari

Forum User
Full Member
Registered: 03/22/04
Posts: 1512
yes. seems to me that you've edited your plugin's index.php.
line 31 should say
Text Formatted Code
require_once("../../../lib-common.php");

 

rather than what it is saying now according to your post:[QUOTE by Michael Heber]Warning: main(../../lib-common.php): failed to open stream[/QUOTE]
notice the difference? ../../../ or ../../
 Quote

All times are EDT. The time is now 02:41 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content