Welcome to Geeklog Friday, May 07 2021 @ 02:50 am EDT

Geeklog Forums

SQL error has occured


Marcus

Anonymous
sad
Hi,

after the scriped hast installed the database, i want to start geeklog index.php. But following happened in the browser window:

An SQL error has occured. Please see error.log for details.


The error.log-file says:
PHP Formatted Code
1064: You have an error in your SQL syntax near ')' at line 1.
SQL in question: SELECT DISTINCT ft_name FROM gl_access,gl_features
WHERE ft_id = acc_ft_id AND acc_grp_id IN ()
 


Than I find the code in lib-security.php:
PHP Formatted Code
$result = DB_query("SELECT DISTINCT ft_name FROM
{$_TABLES["access"]},{$_TABLES ["features"]} "

. "WHERE ft_id = acc_ft_id AND acc_grp_id IN ($glist)");
 


It seems that $glist has some problems because the error.log says null ....

Please help - Thank you!
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Strange. Are you sure all the tables have been created and filled successfully?

Since this appears to be a fresh install, try dropping the tables and running the install script again. Pay close attention to see if any error messages may flash up during the install.

bye, Dirk
 Quote

ccado

Anonymous
Hello,
I have exactly the same problem, even if i re-run install of the database.
At the end of step 2 of 2 of the install, appear a blank page rather than a success message. Then the datbase is empty !

Cry
 Quote

Cara

Anonymous
Hi I'm having this same problem... granted I have never used any kind of CMS before, but this is an automatic install from the control panel of my website... there are several CMS options but this one looked the best... but as someone stated above, it gets to step 3 and instead of finishing, I get the message:

ERROR 1064 at line 1025: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'table `gl_storysubmission` Jan 08, 2004 at 01:00 PM `gl_storysu

Greek to me. All I did was fill in the directory name I wanted it to go to and a user name/password to install it automatically.

I am really new at this and I don't want to just give up before I even begin but this is making me crazy. I thought it was maybe just a glitch of my computer so I deleted and tried again with the same result; deleted, rebooted, same...

If someone could point me in the right direction for either some help or what I can do to fix this, it would be appreciated!

Thanks in advance!
 Quote

Ken Jones

Anonymous
I had a similar error some time ago. In my case it was a broken GL Tarball d/l. I had to redownload the tarball, reinstall GL, and everything worked!
 Quote

Status: offline

michaelaskew

Forum User
Newbie
Registered: 02/09/02
Posts: 7
curious

I use a custom installer script on my sites (I had to beg my hosting provider for SSH access), but curiosity led me to take the Fantastico installer script for a spin anyway and see what it could do.


I'm glad to say it went well. After entering some basic configuration info (site name/slogan, (sub)domain and path, and admin username/pass) I was presented with a fresh installation of Geeklog 1.3.9; unlike the normal geeklog install process, no 'Moderator' account was created, just the one admin account which I had provided the name and password for; the install directory had been removed, so the site was left in a pretty secure configuration.


That said, here's some issues I have with how it was installed:



  • All files were installed in the 'web root' folder, in other words, all the files outside of 'public_html' were moved inside it. This means that by browsing to http://newgeeklogsite.com/system I could see a list of all the files inside it, and I could read all the non-php ones; I could also attempt to execute PHP scripts which weren't intended to stand alone, such as config.php and the Pear libraries. Although I didn't find any ways to cause real trouble, this is pretty bad and could help malicious users find ways to harm your site.

  • No options were provided to help configure the 'emailgeeklogstories' cron job, even though my provider supports cron jobs.

  • None of the optional image libraries were configured, even though my service provider has both NetPBM and ImageMagick installed.

 Quote

Noah

Anonymous
I had this problem as well until I realized that although the table schema was being created sucessfully during the installation, the tables weren't being populated with the initial records. From the "acc_grp_id IN ()" that you're getting, there should be something in the parentheses. The empty parentheses is causing your error. Your initial geeklog database should not be empty and many of the tables should have records in them if your installation was sucessful.

Ultimately, my problem was my database user account didn't have enough privileges to the geeklog database for a successful installation. Once I had the privileges set right, I dropped the geeklog database with the empty tables and re-ran the installer and all was well.
 Quote

All times are EDT. The time is now 02:50 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content