Welcome to Geeklog, Anonymous Friday, July 12 2024 @ 04:14 pm EDT

Geeklog Forums

Warning: main(): Unable to access on line 110


Status: offline

NeoNecro

Forum User
Regular Poster
Registered: 02/07/04
Posts: 90
stressed
Hey, I've heard so mutch good things about geeklog, that I decided to give it a go.
But I encounter several problems with the installation.
At the begining of the install.php page I get this error: "Warning: ini_get, ini_alter, ini_restore, ini_set, getrusage, mysql_list_dbs, get_current_user, set_time_limit, getmyuid, getmypid, dl, leak, listen, chown, chmod, chgrp, realpath, tmpfile, link, mb_send_mail() has been disabled for security reasons in /data/members/free/tripod/nl/d/i/m/dimissite/htdocs/geeklog/public_html/admin/install/install.php on line 103"

Then somewath later I get this warning: "Warning: You have register_globals = Off in your php.ini. However, Geeklog requires register_globals to be on. Before you continue, please set it to on and restart your web server."

On the next page I get only this: "Warning: main(): Unable to access /path/to/geeklog/system/databases/mysql.class.php in /data/members/free/tripod/nl/d/i/m/dimissite/htdocs/geeklog/system/lib-database.php on line 110

Warning: main(/path/to/geeklog/system/databases/mysql.class.php): failed to open stream: No such file or directory in /data/members/free/tripod/nl/d/i/m/dimissite/htdocs/geeklog/system/lib-database.php on line 110

Fatal error: main(): Failed opening required '/path/to/geeklog/system/databases/mysql.class.php' (include_path='.:/data/apache/php/mmp_lib') in /data/members/free/tripod/nl/d/i/m/dimissite/htdocs/geeklog/system/lib-database.php on line 110"

Is there anybody who can help me with this problem?
I've tried the hack I'vi found in this threath, but it doesn't seem to work, or maybe I'm not doing something rong.

grtz
dimis-site.be
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
There are several things here.

The warning about ini_get etc. being disabled can safely be ignored. The install script tries to switch certain error messages on in order to help track down possible problems during installation. It seems your hosting service has decided to disable that ability. It shouldn't be a problem, although it may make it more difficult to track down errors that may happen during the install.

The warning about register_globals being of is more severe. Geeklog requires register_globals being on. The FAQ covers all that can be said on that topic. But if you can't switch register_globals on in one way or another, then you will not be able to use Geeklog.

The third issue you have is related to your paths not being set correctly. The error message refers to "/path/to/geeklog" which indicates that you forgot to change one of the paths in config.php or lib-common.php. Please read the installation instructions again carefully.

bye, Dirk
 Quote

Status: offline

NeoNecro

Forum User
Regular Poster
Registered: 02/07/04
Posts: 90
Thx for the help! Big Grin
I've fixed al those thinx en could finish the installation. Now the blog looks really f*cked up. Come and have a look. The think thats because of the register_globals are off.
I've send an e-mail to my host and asked who I have to make a .htaccess file. I don't know who to do this.
By the way, do you guys have an release date in mind for Geeklog 2.0?? I've read in in the FAQ that this version wouldn't need to have globals on.

bey

/edit
The Geeklog works!! Without register_globals on!! Thanks to the hack I found on this forum. Go and have a look!. Tomorow I will begin to configurate it.
dimis-site.be
 Quote

All times are EDT. The time is now 04:14 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content