Welcome to Geeklog, Anonymous Wednesday, April 17 2024 @ 10:49 am EDT

Geeklog Forums

Xchange Server Running but no email to new users


Status: offline

ola_one

Forum User
Full Member
Registered: 06/28/03
Posts: 186
Hello again,

I thought that if I have SMTP running in any form, then I should not have any problem with my newly registered users getting their password, but I still cannot get users to get their password even though, MS Xchange 2000 is running on the same server and I can get email through to the mail server.

Is there something else that I need to do to make Geeklog send the new users their passwords?

Thanks in advance

Ola
 Quote

Status: offline

Tony

Site Admin
Admin
Registered: 12/17/01
Posts: 405
Location:Urbandale, Iowa
What did you supply as settings to the mail related items in config.php? Also, I assume you have PEAR installed either with your PHP version or via the tarball on this site, right (specifically PEAR::Mail)?
The reason people blame things on previous generations is that there's only one other choice.
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Earth to Tony: Support for PEAR::Mail is not out yet - that will come in Geeklog 1.3.9 ... Mr. Green

bye, Dirk
 Quote

Status: offline

Tony

Site Admin
Admin
Registered: 12/17/01
Posts: 405
Location:Urbandale, Iowa
Correct, sorry, I assumed some feature updates already in CVS were added with sr4. My bad.
The reason people blame things on previous generations is that there's only one other choice.
 Quote

Status: offline

ola_one

Forum User
Full Member
Registered: 06/28/03
Posts: 186
Tony wrote:
What did you supply as settings to the mail related items in config.php


I have searched my config.php and found the following:

// This is the return address for all email sent by Geeklog:
$_CONF['site_mail'] = 'ola_one@atb-associates.com';

I changed the address from ola_one@yahoo.com to ola_one@atb-associates.com and atb-associates is my domain in a win2k environment.

I also see these under Miscellaneous Settings.

$_CONF['emailuserloginrequired'] = 0;
$_CONF['emailstoryloginrequired'] = 0;

And that is all I could see in relation to site mail.

Thank you

Ola
 Quote

Whoosh

Anonymous
Perhaps you didn't set the SMTP settings in config.php (I assume you are running a CVS version.)
 Quote

Status: offline

vinny

Site Admin
Admin
Registered: 06/24/02
Posts: 352
Location:Colorado, USA
Geeklog (1.3.8) uses php's built in mail handling which is setup in the php.ini for your php installation. Make sure the settings are correct there for your mail server. They make sure that PHP can send mail. Perhaps a simple test script would be a good idea.

-Vinny
 Quote

Status: offline

ola_one

Forum User
Full Member
Registered: 06/28/03
Posts: 186
I have copied the PHP.ini section below:

The sendmail_from used to be ola_one@yahoo.com. I have changed that to ola_one@feyiola.com (The email address on the exchange server)

[mail function]
; For Win32 only.
SMTP = localhost

; For Win32 only.
sendmail_from = ola_one@feyiola.com

The question is Should SMTP = localhost or should it be changed thethe server name?

I have not tested it yet, but I just want to confirm if localhost is good enough?

Thanks to all for your help

Ola
 Quote

Keil

Anonymous
I went thru same issues a week ago...no outbound smtp with geekog on win2003/Exchange 2003.

Needed to change:

[mail function]
; For Win32 only.
SMTP = my.domain.com as registered in DNS

SMTP = Localhost did not work

Not sure if local IP will work?

Additionally, I think?, Exchange relay default settings allow local mailers (on your server...in this case, Geeklog) to relay to internet. Check your Exchange relay settings, just in case.
 Quote

All times are EDT. The time is now 10:49 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content