Welcome to Geeklog, Anonymous Monday, January 30 2023 @ 09:46 am EST

Geeklog Forums

Background Image - Am I missing something???


TBG

Anonymous
In the header.thtml, I have this:



But...the background image does not show up...and the bg.gif image is in a folder called images.

The strange thing is, if I put header.thtml on my desktop and change the extension to html...put the images folder on my desktop with the bg.gif in it, it works fine.

Am I missing something here? I've tried everything. Thank you.
 Quote

TBG

Anonymous
Here's the code:

<body bgcolor="#E1F9DB" text="#000000" background="images/bg.gif" leftmargin="0" topmargin="0" marginwidth="0" marginheight="0">
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
There are several images folders - one for Geeklog (in the same directory where lib-common.php resides) and one in each theme directory.

You should be using the {site_url} and {layout_url} variables to specify which one you actually mean, e.g.

{layout_url}/images/bg.gif

bye, Dirk
 Quote

TBG

Anonymous
My mistake, of course. I had the wrong permissions on the actual image for some reason. NO READ PERMISSIONS. Thanks.
 Quote

Status: offline

1PLM

Forum User
Chatty
Registered: 07/11/08
Posts: 39
Hi, I just did a little edit to our sites header background image, I uploaded it back to the Themes directory at my websites dot com/layout/professional/images/header-bg.png and It's not showing up now.
However header-bg.png exists in its location at:my websites dot com/layout/professional/images/header-bg.png if typed in the address bar.

The code below is seen in blockheader-message.thtml:

<div style="font-weight:bold;width:95%;margin:10px;border:1px solid black;">
<div style="padding:5px;color:#FFFFFF;background:url({layout_url}/images/header-bg.png) #1A3955;">
<span class="floatright">{block_help}</span>
{showhide}
{block_title}
</div>
<div style="padding:5px 15px 5px 15px;border-top:3px solid black;background:#E7E7E7;">

Thanks.
 Quote

Status: offline

1PLM

Forum User
Chatty
Registered: 07/11/08
Posts: 39
Panicked a bit. Keep Calm and refresh or reload browser to see Changes Effected!..
Thanks.
 Quote

All times are EST. The time is now 09:46 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content