Welcome to Geeklog, Anonymous Monday, June 17 2024 @ 04:08 pm EDT

Geeklog Forums

Help! Can't change admin pwd


DJDevon3

Anonymous
I've installed and everything went ok till I tried changing the admin password. it spit out this error:

Warning: fopen(/home/southflo/public_html/logs/error.log): failed to open stream: Permission denied in /home/southflo/public_html/lib-common.php on line 1576
1064: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'WHERE gl_users.uid = 2 AND .uid = 2' at line 1
 Quote

DJDevon3

Anonymous
NEED Help
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
You get the warning about error.log because you didn't change the permissions for the log directory (and the two files in there) properly. Please re-read that section of the installation instructions.

The second error irritates me. Is this displayed in your browser? It shouldn't do that - Geeklog is supposed to only say "there was an SQL error - please check your error.log". And error.log would then hold the complete SQL request that caused the error. Without that information, it's hard to tell what the problem is.

bye, Dirk
 Quote

djdevon3

Anonymous
confused
i've changed /logs and files to 777 still same error. i can't recreate the table without using the web installer. originally i tried creating the tables manually using query but it would spit errors at me everytime. this isn't cool.
 Quote

djdevon3

Anonymous
and why can't i edit my post. please turn edit back on in case i might have an update before a reply comes. thanks, bye.
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by djdevon3: and why can't i edit my post. please turn edit back on in case i might have an update before a reply comes. thanks, bye.

Nothing has been turned off - you just need to make sure you're logged in when you post. For your last two posts, you were not logged in.

bye, Dirk
 Quote

DJDevon3

Anonymous
doh, ok but now i have to login everytime i come to geeklog. my cookie is set for 1 year.
 Quote

All times are EDT. The time is now 04:08 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content