Welcome to Geeklog Friday, August 07 2020 @ 02:21 pm EDT

Geeklog Forums

Problem, cannot log in as admin or mod...


Will

Anonymous
Install went fine it seems, site loads ok, but cannot log in as Admin or Mod with initial presets. Also, cannot join as a member due to the fact that no e-mail conformations are being sent. Any ideas here?
 Quote

Status: offline

DTrumbower

Forum User
Moderator
Registered: 08/01/03
Posts: 507
Sounds like register_globals=off issuer, should be on. The install script should of warned you if it was off.
 Quote

Will

Anonymous
Where can I find that file to change it, if that is possible?
 Quote

Status: offline

DTrumbower

Forum User
Moderator
Registered: 08/01/03
Posts: 507
It is in your php.ini. If you are on a shared host then you can\'t change it. You can confirm by using geeklog/admin/install/info.php It will list all the php variables
 Quote

Will

Anonymous
I checked that as per the install instructions, everything was okay..
 Quote

ttraub

Anonymous
I am having the same problem. Installed everything, file permissions all set, can't log in. I have confirmed that the md5 encoding of gl_users.passwd is 'password' for Admin and Moderator. register_globals is set to 'yes'. error.log and access.log don't contain any information. Any help would be appreciated!
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
First of all, your browser will have to accept cookies (but I assume you already checked that?). In case your URL includes a port number (something like example.com:8080), you will need to set the $_CONF[\'cookiedomain\'] variable in config.php (to \'.example.com\'), as there\'s a minor bug in Geeklog that prevents the auto-detection of that value when a port number is involved. The only other issue I can think of involves having cookies from a pre-1.3.8 install in your browser, but that doesn\'t seem to apply here. bye, Dirk
 Quote

Flashone

Anonymous
hopeful
I\'m having the same problem and cannot login as admin or moderator. Did everything above nothing worked. It logs me in and throws me out right a way! Please help!
 Quote

ckelley

Anonymous
Check your php.ini and ensure that you have globals turned on. register_globals = On
 Quote

Status: offline

jlewis

Forum User
Newbie
Registered: 17/12/01
Posts: 7
The same thing is happening to me. I just upgraded to 1.3.8-1sr2, and now can't log in as a user. When I log it, it accepts me, then dumps me back to the un-logged in page.

Register Globals is ON, and I removed all old cookies related to this site.

Help!
 Quote

Status: offline

jlewis

Forum User
Newbie
Registered: 17/12/01
Posts: 7
I take that back, i'm seeing

Failed to set session cookie

in the geeklog/log/error.log

Ideas?
 Quote

Whoosh!

Anonymous
Try removing the cookie domain altogether. I did this just as a test and was able to login as Admin.
 Quote

clvrmnky

Anonymous
Quote by Whoosh!: Try removing the cookie domain altogether. I did this just as a test and was able to login as Admin.

No good for me. Just installed 1.3.8, and no combination of PHP configs or cookie munging will allow me to login with a regular userID or Admin.

Tried a variety of browsers, with cookies fully accepted. The cookie is not even showing up in the browser's cookie cache, so something is keeping it from being set, or accepted. Reset the web space perms and ownership, just to be sure.

BTW, the logs/error.log contains very few entries -- from when I tried to access the plugins w/o logging in. No cookie or connection errors are being logged.
 Quote

Status: offline

jager

Forum User
Newbie
Registered: 13/11/03
Posts: 12
Quote by clvrmnky: Try removing the cookie domain altogether. I did this just as a test and was able to login as Admin.
No good for me. Just installed 1.3.8, and no combination of PHP configs or cookie munging will allow me to login with a regular userID or Admin.

Tried a variety of browsers, with cookies fully accepted. The cookie is not even showing up in the browser's cookie cache, so something is keeping it from being set, or accepted. Reset the web space perms and ownership, just to be sure.

BTW, the logs/error.log contains very few entries -- from when I tried to access the plugins w/o logging in. No cookie or connection errors are being logged.



I had this problem too - but I fixed it to some degree. Are you using domain forwarding from a third party (like mydomain.com)? If so, that may be your problem. I'd log in and it would just show me the login screen again. You can try it out on my site and see if you have the same problem - it does seem to be browser specific though - even though I can't figure out how yet.

To see if you're having the same problem as I am, go to http://www.shotaway.com and log in. If that doesn't work, then you're having a problem with how your browser handles the domain forwarding. I think mine is set up like a 1 pixel frame or something so you can't see it. Anyway, if you go to http://www.meer.net/voccg/film/public_html - which is what the URL is without domain forwarding - and your username and password works, that's your problem.

It's definitely a strange problem... but it's not geeklog specific. It's browser...at least in clvrmky's case.
 Quote

scholl

Anonymous
I had similar problems: I have two geeklog sites on the same server, one was using domain forwarding from a 3rd party site and I had similar problems with not being able to login. My geeklog site would show me logged in, but I couldn't access anything. I could login if I deleted cookies and then entered the site through the real url without using the forwarded domain.

I Finally figured out that if I set the
privacy settings in Windows XP to "low" it would let me log in using the forwarded domain.

On my geeklog site that didn't use domain forwarding my privacy setting didn't have to be
on "low".

Anyway, figured this may help somebody.
 Quote

george bray

Anonymous

On MacOS X I had to try a couple of browsers before being able to login as admin. Cookie/privacy settings are a likely culprit.

 Quote

Sean

Anonymous
determined
Same problem but with soem extra information:

I can log in correctly using Firebird (Mozilla) and all is perfectly well. However, when I use IE it pretends to log me in (I see the user logged in on the right hand side box) but still shows me the login box on the left and won't allow me to do anything as that user.

So it appears that the system thinks I'm logged for some purposes, but my browser (IE only) tells it I'm not and it then refuses to give me access.

I don't mind personally (as I use Firebird), however my readership certainly will!

Any pointers? I downloaded and installed only yesterday so I have the latest version. It sounds like a cookie/browser/user problem with the latest patch.

Rgds
Sean
 Quote

Sean

Anonymous
Whoops. Didn't read all the posts. Yes, me site is having URLs forwarded and that would appear to force the problem with IE under XP.

Surely, there must be a tweak we can do in the code to get it to work with these browser combinations? I can't ask all the users to change their IE settings to LOW!!

Any suggestions? (Of course I can get a fully blown domain but I was going to wait for a while before I did that. No sense wasting money.)
 Quote

Anonymous

Anonymous
I have the exact same problem...I can go to my login page by typing the ip address instead of the domain name for the url, and the login works fine..if I type the domain name to get there, it'll show the login page, and continue to do so even though I try to log in. I'm using Win XP/IE on a php/apache server
 Quote

Status: offline

larry

Forum User
Newbie
Registered: 06/08/04
Posts: 2
I had this problem with the session cookies; however, not with a new install... things were working then got messed up. A plugin I'm developing was the culprit.

I was able to finger point at the plugin after I discovered that I could login when the plugin was disabled (via brute force SQL hack to gl_plugins.pi_enabled).

The problem is now solved. Although I tried a few things, I think the solution was to remove any blank lines after the php end tag at the end of my plugin's functions.inc (as suggested @ squatty.com).

Hopefully this info will benifit others.
 Quote

All times are EDT. The time is now 02:21 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content