Welcome to Geeklog, Anonymous Wednesday, February 01 2023 @ 05:56 pm EST

Geeklog Forums

Calendar only works for Guest


Status: offline

LewisR

Forum User
Junior
Registered: 06/30/03
Posts: 29
I was sure I\'d tested this before, but for some reason, Calendar only seems to work if I\'m completely logged out. Once I log in, I can\'t access the sitewide calendar or the personal calendar. Any ideas? (BTW, by \"can\'t access\" I mean that I get a blank page with an error from my local Squid proxy that it received a zero length reply.) TIA ----- Lewis --------------------------------------------------------- Lewis G Rosenthal, CNA Rosenthal & Rosenthal Accountants / Network Consultants New York / Northern Virginia www.2rosenthals.com Team OS/2 / NetWare Users Int\'l www.whytheylie.com ---------------------------------------------------------
Lewis Rosenthal, CNA, CLP, CLE
Rosenthal & Rosenthal, LLC
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by LewisR: I was sure I\'d tested this before, but for some reason, Calendar only seems to work if I\'m completely logged out.
Hmm, haven\'t seen this before. Any error messages anywhere (in Geeklog\'s error.log, in the webserver\'s logfile)? bye, Dirk
 Quote

Status: offline

LewisR

Forum User
Junior
Registered: 06/30/03
Posts: 29
Thanks (again) for the quick reply, Dirk. unfortunately, I didn\'t catch your post until a couple minutes ago. Nope. Nothing to indicate that there\'s anything wrong. Is there any user authentication checking done when accessing the main calendar, e.g., if one isn\'t logged in, would he see the same main calendar as a user who was indeed logged in? ----- Lewis --------------------------------------------------------- Lewis G Rosenthal, CNA Rosenthal & Rosenthal Accountants / Network Consultants New York / Northern Virginia www.2rosenthals.com Team OS/2 / NetWare Users Int\'l www.whytheylie.com ---------------------------------------------------------
Lewis Rosenthal, CNA, CLP, CLE
Rosenthal & Rosenthal, LLC
 Quote

Status: offline

LewisR

Forum User
Junior
Registered: 06/30/03
Posts: 29
Quick follow-up... When I bypass my proxy and click on one of the calendar links while logged in, I get a quick wait pointer and then nothing. The page doesn\'t change. I don\'t get the zero length reply which Squid presents to me. FWIW. Lewis
Lewis Rosenthal, CNA, CLP, CLE
Rosenthal & Rosenthal, LLC
 Quote

Status: offline

LewisR

Forum User
Junior
Registered: 06/30/03
Posts: 29
This problem persists, even after I\'ve cleared up my other MySQL timeout issues (which appear to be related to the NetWare implementation of MySQL, and not the PHP build on my OS/2 Apache server). Anyway, I\'ve temporarily moved the MySQL databases to a W2K box, and the timeouts have cleared up. However, the calendar problem is perplexing. Again, if I\'m logged in, I can\'t access either the master calendar or my personal one (tried with a couple different logins, too). If logged out, I can easily open the master calendar. Any ideas as to where in the calendar.php I might look to be sure that the paths are correct, etc.? TIA
Lewis Rosenthal, CNA, CLP, CLE
Rosenthal & Rosenthal, LLC
 Quote

Status: offline

LewisR

Forum User
Junior
Registered: 06/30/03
Posts: 29
I just tried turning off personal calendars. Once logged in, clicking on the Calendar menu item leaves me with a zero-length reply. Assuming the personal calendars actually do turn off by setting the flag in config.php, then this problem doesn\'t have anything to do with personal calendars at all, and is probably more related to changes in the site when a user is logged in (login is not required for calendar access). Enabling login for calendar access has no effect on this (other than receiving the prompt to log in when attempting to access the calendar and not already logged in. Upon logging in, the same problem appears. Anyone? Thoughts? Ideas? TIA
Lewis Rosenthal, CNA, CLP, CLE
Rosenthal & Rosenthal, LLC
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by LewisR:Anyone? Thoughts? Ideas?
Nope, sorry. No idea why this is happening for you. It doesn\'t for me and I can\'t explain it from the source either ... bye, Dirk
 Quote

Status: offline

LewisR

Forum User
Junior
Registered: 06/30/03
Posts: 29
Thanks, Dirk. I did some looking over at geeklog.ca, which gave me some tineresting things to check out, namely, any interaction with magic_quotes (I foolishly turned on magic_quotes_gpc, though runtime is off). I turned off magic_quotes_gpc, but no dice. I\'ve looked through calendar.php, lib-common.php, and calendar.class.php, and still can\'t figure out why it stalls when I\'m logged in. I\'ve even tried a couple different themes (I have custom themes on my site almost exclusively, but for this, I was using Smooth Blue, which still stalls in the same place). If I enable $_COM_VERBOSE in lib_common.php, that only produces output from calls made from lib_common, correct? Is there any other logging I might enable to see where it\'s failing?
Lewis Rosenthal, CNA, CLP, CLE
Rosenthal & Rosenthal, LLC
 Quote

Status: offline

LewisR

Forum User
Junior
Registered: 06/30/03
Posts: 29
Still this annoying situation... Perhaps it's a database problem? GL is querying the db server (different boxes over here, though the symptom would probably be the same), and there's corruption in the db relating to personal calendars? Any way to check this?

Lewis Rosenthal, CNA, CLP, CLE
Rosenthal & Rosenthal, LLC
 Quote

Status: offline

ckelley

Forum User
Newbie
Registered: 10/16/03
Posts: 2
Has anyone solved this problem? I too am having the same issues. OS is Solaris using IPlanet as the webserver. All of the other links work fine win logged in as administrator except for calendar. Nothing showing up in the logs. I even added additional log statements and nothing. Works fine on my local box running win2k under apache. I believe it has something to do with cookies. Have to log out and then view the calendar as an anonymous user.
 Quote

All times are EST. The time is now 05:56 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content