Welcome to Geeklog Thursday, December 05 2019 @ 09:42 pm EST

Geeklog Forums

Challenge with Geeklog/Gallery Integration


Status: offline

juddly

Forum User
Newbie
Registered: 22/07/03
Posts: 4
freakingout
Team, Having a little problem with the integration of Geeklog and the Gallery software. I have successfully installed Gallery 1.3.3 and am using Geeklog 1.3.8r2. (loving it by the way, if I could only get past this Gallery issue!) Here\'s the trick: after performing the install, and trying to go to my public_html/gallery URL, I get the text from User.DB dumped into the page (after View Source, I can see it all, including the comments!) and the following error message: Fatal error: Cannot instantiate non-existent class: geeklog_user in /my_path_to_public_html/gallery/classes/geeklog/UserDB.php on line 76 (paths changed to protect the innocent.) As a point of reference, I am using the \"gallery_1.3.3_1.3.7r3.tar.gz\" integration instructions and package, as I could not locate a gallery_1.3.3_1.3.8r2 package. HELP! Cry Thanks.
 Quote

Status: offline

Euan

Forum User
Full Member
Registered: 22/04/02
Posts: 292
dizzy
I have the same gallery running OK with GL 1.3.8. There are a couple of files that you have to replace including init.php. I seem to remember going through that and inserting the relevant bits for GL myself - the init.php file has changed since the last Gallery version. HTH
-- Heather Engineering -- No job too small
 Quote

Status: offline

juddly

Forum User
Newbie
Registered: 22/07/03
Posts: 4
cheerful
So are you suggesting that I should upgrade to GL 1.3.8? Is this by any chance an offer to compare files? heh-heh... I am also trying out Geekary, but it is not letting me upload files. The Gallery software seems a little higher-quality, but for all I know they have the same engine. Please let me know the level of effort (if any) to which you are open. Thanks!
 Quote

Status: offline

jlhughes

Forum User
Full Member
Registered: 25/04/02
Posts: 154
thoughtful
Fatal error: Cannot instantiate non-existent class: geeklog_user in /my_path_to_public_html/gallery/classes/geeklog/UserDB.php on line 76
Did you make the required changes to Gallery\'s config.php? The Geeklog 1.3.7-Gallery 1.3.4 intergration works with Geeklog 1.3.8 and the two release candidates.
 Quote

All times are EST. The time is now 09:42 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content