Subject: Challenge with Geeklog/Gallery Integration

Posted on: 23/07/03 04:42pm
By: juddly

Team, Having a little problem with the integration of Geeklog and the Gallery software. I have successfully installed Gallery 1.3.3 and am using Geeklog 1.3.8r2. (loving it by the way, if I could only get past this Gallery issue!) Here\'s the trick: after performing the install, and trying to go to my public_html/gallery URL, I get the text from User.DB dumped into the page (after View Source, I can see it all, including the comments!) and the following error message: Fatal error: Cannot instantiate non-existent class: geeklog_user in /my_path_to_public_html/gallery/classes/geeklog/UserDB.php on line 76 (paths changed to protect the innocent.) As a point of reference, I am using the \"gallery_1.3.3_1.3.7r3.tar.gz\" integration instructions and package, as I could not locate a gallery_1.3.3_1.3.8r2 package. HELP! Cry Thanks.

Re:Challenge with Geeklog/Gallery Integration

Posted on: 23/07/03 08:09pm
By: Euan

I have the same gallery running OK with GL 1.3.8. There are a couple of files that you have to replace including init.php. I seem to remember going through that and inserting the relevant bits for GL myself - the init.php file has changed since the last Gallery version. HTH

Re:Challenge with Geeklog/Gallery Integration

Posted on: 24/07/03 08:02am
By: juddly

So are you suggesting that I should upgrade to GL 1.3.8? Is this by any chance an offer to compare files? heh-heh... I am also trying out Geekary, but it is not letting me upload files. The Gallery software seems a little higher-quality, but for all I know they have the same engine. Please let me know the level of effort (if any) to which you are open. Thanks!

Re:Challenge with Geeklog/Gallery Integration

Posted on: 24/07/03 02:16pm
By: jlhughes

Fatal error: Cannot instantiate non-existent class: geeklog_user in /my_path_to_public_html/gallery/classes/geeklog/UserDB.php on line 76
Did you make the required changes to Gallery\'s config.php? The Geeklog 1.3.7-Gallery 1.3.4 intergration works with Geeklog 1.3.8 and the two release candidates.

Geeklog - Forum
https://www.geeklog.net/forum/viewtopic.php?showtopic=22356