Welcome to Geeklog, Anonymous Sunday, October 02 2022 @ 12:24 am EDT

Geeklog Forums

*sigh* db install script - access denied


Status: offline

tstockma

Forum User
Full Member
Registered: 07/22/03
Posts: 169
I\'m lookin\' for ideas. I\'m trying to install for the first time, the hosting service\'s phpMyAdmin ain\'t working so I used the CLI to create a db, and it seems to exist. I\'m now executing the install.php script, and getting the \"access denied\" error. In config.php, I\'ve tried lots of variations, but no luck. _DB_host is set to the IP of the machine I\'m on, _DB_name is the database name...and I can connect to it via the CLI, so I think it\'s there..._DB_user is \"root\", while I try to perform the initial install, and _DB_password is correct. Anybody got any ideas? I\'m fairly new to this style of database, I\'d love to try \"connect strings\" in several different flavors, just to see if I can get in with my current settings of hostname & user/pass. Thanks for any help! tstockma ftuck@frii.com
Tom
www.southparkcity.com
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by tstockma:I\'m now executing the install.php script, and getting the \"access denied\" error.
This one? bye, Dirk
 Quote

tstockma

Anonymous
No, but it\'s got an entry in the troubleshooting section. It\'s this one: Warning: Access denied for user: \'website@localhost\' (Using password: YES) in /usr/local/www/vhosts/southparkcity.com/geeklog-1.3.8/system/databases/mysql.class.php on line 104 Warning: MySQL Connection Failed: Access denied for user: \'website@localhost\' (Using password: YES) in /usr/local/www/vhosts/southparkcity.com/geeklog-1.3.8/system/databases/mysql.class.php on line 104 Cannnot connect to DB server I\'ve tried using the mySQL root acct/pw, I\'ve set up another account (website) in phpMyAdmin & it fails also. I also replaced \'localhost\' with the IP of my server before returning to \'localhost\'. The path to my doc root (and I moved lots of files there, I\'m using the std install instructions plus Andrew Gray\'s article from PHP Architect) is: /usr/local/www/vhosts/southparkcity.com/htdocs/ The path to geeklog & the config file is: /usr/local/www/vhosts/southparkcity.com/geeklog-1.3.8/ And I\'ve destroyed & recreated the database a couple times. Thanks for any suggestions, this has me thoroughly stopped. Tom
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Oops, sorry - I just realised I gave you the wrong link. Oops! But you found the one I wanted to point you to, it seems. Now, if that didn\'t help and you\'re sure you did everything correctly then I\'m pretty much out of ideas. Try asking your hosting service for help. bye, Dirk
 Quote

Status: offline

craymond

Forum User
Junior
Registered: 07/25/03
Posts: 17
I\'m having the same problem with my database: Warning : Access denied for user: \'me@myhostingcompany.com\' (Using password: YES) in /home/virtual/site6/fst/var/www/html/system/databases/mysql.class.php on line 104 Warning : MySQL Connection Failed: Access denied for user: \'me@myhostingcompany.com\' (Using password: YES) in /home/virtual/site6/fst/var/www/html/system/databases/mysql.class.php on line 104 Cannnot connect to DB server
 Quote

Status: offline

tstockma

Forum User
Full Member
Registered: 07/22/03
Posts: 169
Carymond, I\'m not sure exactly what fixed my problem--it may have been that the ISP fiddled with a few things. However, I\'d recommend putting some time, fiddling & making sure things are copacetic before bugging the ISP. I administered mine using the MyPHPAdmin admin tool for MySQL. My first step at trouble time was the make sure I could connect to the database with the admin tool. I also created a user with less-than-DBA privs, and set up the GeekLog config file to use that; never could get that to work. After extensive fiddling, I went back to the root user/pass in the config file, and it hooked right up. When that happened, I was able to run the database initial config scripts, and the application then got right in. So, obviously I know how to create a user within MyPHPAdmin, but I don\'t know how to then tell a specific database to allow that user access. So far I\'ve left it as-is, I\'ll probably try to learn more & use a less privileged user/pass later. I\'m still unclear why my first attempts to use \'root\' failed, then did work many hours later when I tried it again. I speculate that something was funky about the service on my ISP\'s server, and it took several hours for that root user to be recognized. This may not be much help, but maybe it\'ll spur some ideas. You might also try to destroy/re-create the database a time or two. Good luck! Tom Stockman
Tom
www.southparkcity.com
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
This is the correct link this time ... bye, Dirk
 Quote

Status: offline

tstockma

Forum User
Full Member
Registered: 07/22/03
Posts: 169
Craymond, Dirk\'s link is very important. I\'d already found it before I posted my first article, this bit gave me full confidence in the steps I\'d taken so I was sure I was mostly on-track. And that was confirmed when I finally did connect using root. Make sure you\'re doing what that article says! Tom
Tom
www.southparkcity.com
 Quote

Status: offline

craymond

Forum User
Junior
Registered: 07/25/03
Posts: 17
Tom/Dirk, OK, I\'ve gotten a little further. The script runs and returns: 1050: Table \'gl_access\' already exists When I go to phpMYadmin all the tables seem to have been written, but the site isn\'t running.
 Quote

Status: offline

DTrumbower

Forum User
Moderator
Registered: 01/08/03
Posts: 507
Looks like it partially worked before. I would delete all the tables and install it again. If you still get errors after that, post the errors and link.
 Quote

Status: offline

tstockma

Forum User
Full Member
Registered: 07/22/03
Posts: 169
I think you have 1 of 2 conditions: 1. as DTrumbower suggests, your database-init script ran partically, & you need to destroy all tables & re-run. If it\'s easier, destroy & re-create the database. 2. the init script DID run fine, some other problem is keeping you from running the app. The \"site is not running\" problem you mention is key; are you getting errors suggesting the database is broken, or are you unable to connect when you run geeklog, or something else? The errors you are getting are key. Post a bit more info on those errors when you hit the roadblocks & we\'ll be able to help a bit better. Luck! Tom
Tom
www.southparkcity.com
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by craymond:1050: Table \'gl_access\' already exists
I\'m not usually the person to post \"RTFM\" all the time, but this, too, is explained in the documentation. bye, Dirk
 Quote

Status: offline

craymond

Forum User
Junior
Registered: 07/25/03
Posts: 17
Looks like the same thing happened. In phpMYadmin I see an error: Database parents11211_org_-_main running on localhost PMA Database ... not OK [Documentation ] General relation features Disabled I emailed my ISP for help, I don\'t know if I can do what is required as detailed in the Documentation link in the above error. It reads: $cfg[\'Servers\'][$i][\'pmadb\'] string Starting with version 2.3.0 phpMyAdmin offers a lot of features to work with master / foreign - tables. To use those as well as the bookmark feature you will need to create a new db. To use this functionality as superuser create a new database: create a new database for phpmyadmin:   CREATE DATABASE phpmyadmin; Note that \"controluser\" must have SELECT, INSERT, UPDATE and DELETE privileges on this database. Here is a query to set up those privileges (using \"phpmyadmin\" as the database name, and \"pma\" as the controluser):   GRANT SELECT,INSERT,UPDATE,DELETE ON phpmyadmin.* to \'pma\'@\'localhost\'; do not give any other user rights on this database. enter the databasename in $cfg[\'Servers\'][$i][\'pmadb\']
 Quote

Status: offline

tstockma

Forum User
Full Member
Registered: 07/22/03
Posts: 169
This one\'s pretty odd...Dirk might know easily what parts of the app you\'re having problems with, I don\'t. I\'d try deleted the database entirely & re-creating. Luck!
Tom
www.southparkcity.com
 Quote

Status: offline

craymond

Forum User
Junior
Registered: 07/25/03
Posts: 17
From my ISP: Chris, The PMA features of phpMyAdmin must remain disabled because of security concerns for other users. This will not, however, affect the functionality of the database itself.
 Quote

All times are EDT. The time is now 12:24 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content