Welcome to Geeklog, Anonymous Monday, May 20 2024 @ 11:56 pm EDT

Geeklog Forums

No changes possible after \'perfect\' smooth install


estay

Anonymous
confused
I smoothly installed GL. The checks were okay and i can login as admin etc. 1 thing: Whatever i try; it\'s not possible to add/edit stories, comments, users etc. In general: it\'s not possible to change the db content ! Anybody seen this / know of it ?
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Please make sure register_globals is on (the install script should actually have warned you if it wasn\'t). This is also in the FAQ, btw. bye, Dirk
 Quote

Estay

Anonymous
groggy
Dirk, thanks for your response. Yep, i DID find the comment about it in the faq, sorry for not mentioning it. Even if i change the theme file as suggested it doesnt work (register_globals is just plain ON btw) ! The thing just is i did a clean install, no warning, no upgrade, no left-behinds, nothing. Paths seems to be okay since everything is displaying alright and the site is reacting normaly. If i was able to change just 1 thing on the site i would be glad ! I cant change or delete submissions, add stories etc. In fact everywhere where a SAVE button should save GL just return WITHOUT the saving part !
 Quote

Status: offline

vinny

Site Admin
Admin
Registered: 06/24/02
Posts: 352
Location:Colorado, USA
This is almost certainly a register_globals off issue. To be sure that this option isn't getting changed by .htaccess files or environmental variables create a short php file as follows:

<?php
phpinfo();
?>

Place the php script in your public_html directory and browse to it in a web broswer. If you search for "register_globals" it will tell you whether or not it is enabled.

-Vinny

P.S. Dirk, why not add the above code snippet to the FAQ. It may reduce some of these register_globals questions. Maybe include a phpinfo.php file that just runs phpinfo() in 1.3.8 release to supplement the check.php install file?
 Quote

Esaty

Anonymous
hopeful
Well don\'t wanna be a wise-guy but i did check with phpinfo(). register_globals is defenitely ON ! The only thing i can find which can cause the troubles is that safe_mode is ON. Tia
 Quote

Mark

Anonymous
Nope, guess again. I have a Geeklog site running a-okay with safe_mode on.
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by vinny:Maybe include a phpinfo.php file that just runs phpinfo() in 1.3.8 release to supplement the check.php install file?
There already is one, admin/install/info.php Mark: Can you tell us a bit more about your setup? Apache and PHP versions, for example? bye, Dirk
 Quote

Estay

Anonymous
Welllllll, with the (high ?) risk of being hacked: http://www.dejongdak.nl/volgerlanden/phpinfo.php as you can see: phpnuke is running okay at: http://www.dejongdak.nl/volgerlanden/ regards
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
sad
Hmm, looks okay to me. We\'ve had some similar experiences in this thread. One of the persons there seems to have given up, but it looks like the last one got it working now (marcg / www.pupsatplay.com). Since I\'m pretty much out of ideas at this point, you could try asking him. And if anyone has a solution, it would be nice if you would report back. bye, Dirk
 Quote

Status: offline

vinny

Site Admin
Admin
Registered: 06/24/02
Posts: 352
Location:Colorado, USA
Just an out there guess. But try everything using the english language file and see if you have problems. I think we've seen these problems before with incomplete or problematic language files.

Good Luck,
Vinny

(Sorry about insisting on it being a register_globals problem, that is just what often causes similar problems)
 Quote

Status: offline

DTrumbower

Forum User
Moderator
Registered: 01/08/03
Posts: 507
Are there any messages in error.log or are any messages in your web log?
 Quote

Estay

Anonymous
awake
Well, now i REALLY do want GL to work ! DTrumbower: Nope, de error.log, weblog, access.log are all clean and in order. This thing is bugging me now .. such a nice cms and i can\'t make it work ! Vinny: Why do you think i used a incomplete language file ? I DID copy dutch.php in the language-dir but didn\'t use it and now i\'ve deleted it. So that didn\'t help neither. Dirk: You were right. Marcg / www.pupsatplay.com did solve it ! I posted a mail via this site asking him how he did it, now i guess i\'ve to wait for him to read his mail account and respond ... Well, i was already at risk of being hacked: to see how it (doesn\'t) work): http://www.dejongdak.nl/geeklog/public_html/admin you know how to login ! ************************************* One thing i didn\'t mention is that my site i hosted by a hosting provider (yep those sites do exist) and that i can\'t change anything in the PHP.ini and apache config. This weekend i will install the same code and settings (different paths okay) to my own localhost and will analyse.
 Quote

estay

Anonymous
well, maybe marcq is on holiday ... If someone else has the same problem i do like 2 hear from u. Could solve our problem ...
 Quote

TazMan69

Anonymous
Did you change the php.ini so that it has \'Register Globals=On\'??
 Quote

Raul

Anonymous
Got the same problem,
i´m not sure if you have fixed it by now,
but after reading the FAQ and forums,
It seems we got the same issue at hand.

The only difference is that I do host my own sites,
so I have access to all files needed.
Register_globals=on, and checked,
No problem accessing as Admin,
but no changes even when trying to
change the title of the poll, for instance.
Will keep trying!
Raul Alvaro Fraser
geeklog@uninet.us
http://80.24.65.105/uninet/geeklog/public_html/
 Quote

Raul

Anonymous
Ok, here it is.
It is in the config.php file:

$_CONF['site_url'] = 'http://geeklog.uninet.us;

is WRONG in my case. Instead, it had to be:

$_CONF['site_url'] = 'http://10.0.0.159/uninet/geeklog/public_html';

Which is the real IP, and not the forwaded URL.
Maybe it would be great if it could be specified somewhere, for those who use redirection in their url´s.

Uf! thought it was going to take me ages!
 Quote

timf

Anonymous
I have this same issue.

It's my own server
Linux Redhat 7.2
Apache 1.3.22
mySql 3.23.41
php 4.1.2

globals is ON - see www.vmbf.com/test.php
permissions set correclty - see http://www.vmbf.com/admin/install/check.php
I checked my url and it is correct in my config.php

Everything LOOKS perfect - but I can't change/edit/add a story - or polls or anything.

Correction! I WAS able to change 2 things! I can change my preferred Theme - and if I click on USERS - I can edit/delete the users when logged in as ADMIN - however - if I try to change my settings by going to the Account Information link - it doesn't save it!






 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Quote by timf: Apache 1.3.22
mySql 3.23.41
php 4.1.2

No idea about your actual problem, but a server with such ancient software really shouldn't be connected to the web any more. There are known bugs (and exploits) for at least the versions of MySQL and PHP that you're running, and, IIRC, even for Apache.

Given that, I can only assume how many known bugs are in other system components (including the Linux kernel itself) that can be exploited.

Take that box down ASAP and update it ...

bye, Dirk
 Quote

Status: offline

timf

Forum User
Newbie
Registered: 10/06/04
Posts: 14
Location:Las Vegas
oh thank you soooo much for all the help
 Quote

All times are EDT. The time is now 11:56 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content