Welcome to Geeklog Wednesday, November 25 2020 @ 03:27 pm EST

Geeklog Forums

file management plugin problem


Mark

Anonymous
artistic
I wondered if anyone has experienced a similair problem and tell me how they fixed it. If this is a stupid question then please forgive me as I am quite the amateur at this sort of thing. I am running apache 2 on win xp with php 4.31 I installed the file management plugin and all went well. I set the filemanagment_data file in the webroot folder \"wampp2\" . My geeklog site is a file under the same folder. when I try to upload a file I keep getting the following error : note --> I am using \"|\" to denote a \"backlslash\" since the backslashes get stripped out
Warning: move_uploaded_file(): Unable to move \'|wampp2|tmp|php61.tmp\' to \'c:/wampp2/filemgmt_data/files/tmp/3LQtmL1LU6\' in CNeutralwampp2|htdocs|geeklog3menu|public_html|filemgmt|submit.php on line 93
I tried replacing the the upload directory in the php.ini file with c:wampp2tmp but the same error message keeps coming up Much appreciate any help Mark
 Quote

Status: offline

Blaine

Forum User
Moderator
Registered: 16/07/02
Posts: 1232
Location:Canada
Your error has nothing to do with the php define for tmp directory as the file has been uploaded by PHP ok to the PHP tmp directory. It\'s after confirming it is there that I try to move the uploaded file to the file repository. This is where the error occurs. Double check your paths and permissions to the file repository. Ensure you have a tmp directory as well for the uploaded files and optional thumbnail images as noted in the install doc.
Geeklog components by PortalParts -- www.portalparts.com
 Quote

Mark

Anonymous
artistic
Thanks for the response My filepaths are all correct therefore that leaves permissions. --> I am on win XP home edition with FAT configuration therefore I do not have the ability to set write permissions (I don\'t think). Is it possible that to run the move_uploaded_file() one needs to have NTFS hard drive config so write permissions can be set ?? Has anyone run into a similair problem --> If not I will try changing to NTFS and if is fixes the problem and post my results Much appreciate your assistance Mark
 Quote

All times are EST. The time is now 03:27 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content