Welcome to Geeklog Saturday, May 08 2021 @ 10:01 pm EDT

Geeklog Forums

Help again, lol.. plugin Mdigest


Status: offline

andyofne

Forum User
Chatty
Registered: 31/08/02
Posts: 69
I downloaded and installed the mdigest plugin but it is chocking on a bad SQL statement. Once again, I'm sql-retarded so I'm having trouble finding exactly what's wrong with this one... I tried opening phpmyadmin and running this manually and i get the same error that shows in the log. Here's the sql statement: SELECT tid FROM gl_topics WHERE (owner_id = 12 AND perm_owner >= 2) OR (group_id IN () AND perm_group >= 2) OR (perm_members >= 2) OR (perm_anon >= 2) Here's the error:Thu Apr 24 17:56:36 2003 - 1064: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ') AND perm_group >= 2) OR (perm_members >= 2) OR (perm_anon >= SQL in question: SELECT tid FROM gl_topics WHERE (owner_id = 12 AND perm_owner >= 2) OR (group_id IN () AND perm_group >= 2) OR (perm_members >= 2) OR (perm_anon >= 2) I'm still trying to figure it out and maybe I'll fall in to it by luck but in the meantime, can someone look at this and see if they already have a clue? Thanks much!
 Quote

Status: offline

rawdata

Forum User
Full Member
Registered: 17/02/03
Posts: 236
The problem is this part of the SQL statement: group_id IN () There should be one or more numbers in the parenthesis there. Do you have anything unique in the way you have GL setup??
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
That SQL statement is not part of the Manual Digest plugin - it's in function COM_emailUserTopics() in lib-common.php. As rawdata already pointed out, the empty group list is the problem here. My guess is that you have at least one user that is not a member of any group. However, any user should at least be a member of the "All Users" and "Logged-in Users" groups. bye, Dirk
 Quote

Anonymous

Anonymous
Hi guys, thanks for the info. I did figure out that there was something missing there but I didn't know (couldn't determine) where that particular sql statement was coming from. Appreciate the help. andyofne
 Quote

Anonymous

Anonymous
Strangely enough it was the "group admin" account that had no group assigned.
 Quote

All times are EDT. The time is now 10:01 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content