Welcome to Geeklog, Anonymous Monday, June 24 2024 @ 09:35 pm EDT

Geeklog Forums

Users can vote many times


Status: offline

laurent_godet

Forum User
Newbie
Registered: 02/03/03
Posts: 9
Good morning, I am expreriencing a problem with the poll capability of Geeklog. One of my user make me notice that it is possible to her to click many time on the vote (or submit) button, once she choose what she wants to vote for. Let says she click 15 times on this buton, 15 votes will be counted on the global amount of vote. Does anyone of you know I could prevent such a thing to occurs ??? Many thanks, and have a nice day, Laurent
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Hmm, Geeklog should prevent this from happening. Even if she doesn't accept cookies, Geeklog should record the IP address and block her from voting again for some time. Does this happen only for this user? Which browser does she use? Did you change $_CONF['pollcookietime'] or $_CONF['polladdresstime'] in your config.php? bye, Dirk
 Quote

Status: offline

laurent_godet

Forum User
Newbie
Registered: 02/03/03
Posts: 9
Hie Dirk, Thanks for your help. So, this happens for every user I have (I don't have THAT much user, so ....), we all use IE 6. Yes I change both of these value to set them to 3600. If I have well understood what this mean, it means that the same IP adress can't vote for 1 hour, or that the cookie with the login name will prevent users to vote for 1 hour. Humm i just try to move GL from a host to another one, and now I've got a 'flex scanner ... line 1' ... I see that you laready answer to this type of question some months ago .. I'll take a look at my path ;-)) For the vote, if you wanna see it by yourself, please go to www.caliouaib.com and vote (stat are not so important in fact), but take care, it's in french ;-))
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany
Hmm, your site isn't sending out any cookies. I've set my browser (Mozilla 1.2.1) up to ask me what to do when a site wants to set a cookie and it did not ask me when I visited your site and voted. However, after I voted, I couldn't vote again, so it seems that it did record my IP properly. I don't have IE6, so I can't test that ... It may have something to do with the fact that your site is within a 100% frameset while the actual Geeklog site is on Lycos France (although I doubt that). Do you see any error messages in Geeklog's error.log file that may be related to this? bye, Dirk
 Quote

Anonymous

Anonymous
The log just contain some line regarding illegal access or things like that, but nothing regarding cookies and so on ... But I know that I often have some Internet Explorer error message while trying to reach the homepage. Thanks, Laurent
 Quote

Anonymous

Anonymous
I have the same problem. Server is Unix in the USA. My visitors are angry because of this problem. http://greekads.com/home/gl/public_html/index.php
 Quote

Anonymous

Anonymous
I voted on one of your polls. It allowed me to vote on that poll only one time.
 Quote

All times are EDT. The time is now 09:35 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content