Welcome to Geeklog Wednesday, June 03 2020 @ 01:13 pm EDT

Geeklog Forums

Need help. Want to cry.


Anonymous

Anonymous
I installed GL and wound up at the "success.php" page. Nothing showed up on this and now when loading the index.php, *nothing* happens. I may be totally retarded and missing something obvious, but I'm going crazy. Please help.
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Check that the path to config.php in lib-common.php is correct. This is the #1 reason for blank pages. bye, Dirk
 Quote

Status: offline

Matty

Forum User
Junior
Registered: 01/02/02
Posts: 25
Double check your paths in config.php
Matty
 Quote

Anonymous

Anonymous
Have tried ('/home/miki/geeklog/config.php'), ('geeklog/config.php'), etc. Nothing seems to work. Am I doing something wrong? I didn't edit *anything* but inside the apostrophes.
 Quote

Anonymous

Anonymous
This is what I got, folks! I edited out my website info to protect the innocent! Smile // +---------------------------------------------------------------------------+ // | SERVER SETTINGS | // | | // | All paths must have a trailing slash ('/'). The 'path' value signifies | // | where the config.php (this file) resides | // +---------------------------------------------------------------------------+ $_CONF['path'] = '/home/miki/'; $_CONF['path_system'] = $_CONF['path'] . 'geeklog/system/'; $_CONF['path_html'] = $_CONF['path'] . 'public_html/'; $_CONF['path_log'] = $_CONF['path'] . 'geeklog/logs/'; $_CONF['path_language'] = $_CONF['path'] . 'language/'; $_CONF['rdf_file'] = $_CONF['path_html'] . 'public_html/backend/geeklog.rdf'; $_CONF['backup_path'] = $_CONF['path'] . 'geeklog/backups/'; // +---------------------------------------------------------------------------+ // | SITE SETTINGS | // | | // | These settings help define your Geeklog site. | // +---------------------------------------------------------------------------+ $_CONF['site_name'] = 'Geek Log Site'; $_CONF['site_slogan'] = 'Another Geeky Site'; $_CONF['site_mail'] = 'administrator@incorrigiblegeek.com'; $_CONF['site_url'] = 'http://www.MY URL IS HERE Smile .com/'; $_CONF['site_admin_url'] = $_CONF['site_url'] . 'public_html/admin'; $_CONF['theme'] = 'XSilver'; // default theme $_CONF['layout_url'] = $_CONF['site_url'] . 'public_html/layout/' . $_CONF['theme']; $_CONF['path_themes'] = $_CONF['path_html'] . 'public_html/layout/'; $_CONF['path_layout'] = $_CONF['path_themes'] . $_CONF['theme'] .'/'; $_CONF['allow_user_themes'] = 1; $_CONF['allow_user_photo'] = 1; // 1 = on, 0 = off...flag that allows users to upload self-photo
 Quote

Anonymous

Anonymous
I forgot to say, this is just one of the numorous variations of things I have tried. Frown
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
If /home/miki/geeklog/config.php is really your path to the config.php, then that is the correct thing to put in lib-common.php. When you called up the install script, did it automatically fill in /home/miki/geeklog in the edit field on the first page? Just asking, because that path looks a bit short to me (but if you're on your own server, that is probably okay). So if the path is correct (and the part of your config.php that you posted looks okay, too), then you may have a typo somewhere else in your config.php. You need to enable error reporting to actually see that error: 1) in your php.ini, set display_errors = On (if it isn't already) and restart your webserver 2) in lib-common.php, comment out the line that reads error_reporting(E_ERROR | E_WARNING | E_PARSE); by adding // (two slashes) in front of it. Then try again. Note: You don't need to run you install script again. Your database has already been set up, we're just trying to find a tiny little error here that prevents your page from displaying ... bye, Dirk
 Quote

Anonymous

Anonymous
Now, the error I am receiving is: Fatal error: Failed opening required '/home/miki/language/english.php' (include_path='.:/usr/local/lib/php') in /home/miki/public_html/lib-common.php on line 114 Which, is odd, because in my config.php, language is pointed to geeklog/language and my path is /home/miki/, so it's got to be referencing a different file, maybe? Because, it only says: '/home/miki/language/english.php' above. I double checked to make sure my path is correct in my config.php file. Any ideas? Oh, and, when it gave me the "hint" on the install, my path was: /home/miki/public_html/install, etc. It's because my friend is doing my hosting for me. Smile Thanks
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Id didn't notice this before, but you seem to be missing a "geeklog" in your paths somewhere. You have $_CONF['path'] = '/home/miki/'; $_CONF['path_system'] = $_CONF['path'] . 'geeklog/system/'; This is not the right way to do it. It should read $_CONF['path'] = '/home/miki/geeklog/'; $_CONF['path_system'] = $_CONF['path'] . 'system/'; Leave all the path variables as they were in the original config.php. Set only $_CONF['path'] to point to the directory where your config.php is. If you've moved or renamed the public_html directory, then you also need to adjust $_CONF['path_html']. But if you left it were it was (inside the geeklog directory), then you don't need to change that. bye, Dirk
 Quote

Anonymous

Anonymous
Heh... No, I didn't leave it where it was because in the install instructions it said "if you already have a public_html file, copy these files there." If I left the 'path' as /home/miki/geeklog, then it was trying to search for my public_html files in /geeklog, but they weren't there, they were in /home/miki/public_html. As this caused too many problems, and with a little coercing from the people in #geeklog (which I can only get on at home - night), I moved the geeklog public_html files into the geeklog directory. Now I'm getting all new errors. I'm going to attempt to fix them for a while, then undoubtedly post them here. Smile But, at least I saw the "welcome to your new geeklog" page, if even for a moment. Razz Thanks.
 Quote

All times are EDT. The time is now 01:13 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content