Welcome to Geeklog, Anonymous Wednesday, July 24 2024 @ 11:37 pm EDT

Geeklog Forums

yet another error for a newb


viperstrike

Anonymous
I got past my last error and now I get this: Warning: Unable to access /usr/local/psa/home/vhosts/viperstrike.net/httpdocs/gl/public_html/config.php in /usr/local/psa/home/vhosts/viperstrike.net/httpdocs/gl/public_html/lib-common.php on line 45 any ideas?
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany

Your config.php is not in public_html (at least I hope it's not).

Please read the installation instructions again carefully. The path in lib-common.php should point to your config.php which is /path/to/geeklog, not in /path/to/geeklog/pubic_html

bye, Dirk

 Quote

viperstrike

Anonymous
Thanks Dirk! one more question for you. now the page loads but I get this error up top Warning: Supplied argument is not a valid File-Handle resource in /usr/local/psa/home/vhosts/viperstrike.net/httpdocs/gl/public_html/lib-common.php on line 741 Warning: Supplied argument is not a valid File-Handle resource in /usr/local/psa/home/vhosts/viperstrike.net/httpdocs/gl/public_html/lib-common.php on line 742 Warning: Supplied argument is not a valid File-Handle resource in /usr/local/psa/home/vhosts/viperstrike.net/httpdocs/gl/public_html/lib-common.php on line 743 and on those lines this is what it reads: fputs ( $file, "</channel>\n"Wink; fputs ( $file, "</rss>\n"Wink; fclose( $file ); thank you for your help, Geeklog is awesome!
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany

And again: It's all in the installation instructions ...

You did not set the access rights for the backend directory and the file therein correctly. Make sure that both the backend directory and the geeklog.rdf file in that directory are set to 775.

While you're at it, you may want to make sure that you did the same thing for the logs directory and the two files therein.

bye, Dirk

 Quote

viperstrike

Anonymous
Hey Dirk, I already had them all set to 775 and it was not working I just tried 777 and that worked for me. is there any problem with using 777 instead of 775? thanks again for you help
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 01/12/02
Posts: 13073
Location:Stuttgart, Germany

It should work with 775 if the files are owned by the user under which your webserver is running (as explained in step 3 of the installation instructions).

Using 777 will give anyone write access to theses files and folders which could in theory become a security risk (although I can't think of any exploit of this right now). It's always good practice not to give more access rights as needed, just in case ...

bye, Dirk

 Quote

viperstrike

Anonymous
ok i'll have to check that everything works except for the admin block the URL for each item is messed up I get http://www.viperstrike.net/usr/local/psa/home/vhosts/viperstrike.net/httpdocs/gl/public_html/admin/link.php i assume i have messed up my config.php file this is what i have: $_CONF['path'] = '/usr/local/psa/home/vhosts/viperstrike.net/httpdocs/gl/'; $_CONF['path_system'] = $_CONF['path'] . 'system/'; $_CONF['path_html'] = $_CONF['path'] . 'public_html/'; $_CONF['path_log'] = $_CONF['path'] . 'logs/'; $_CONF['path_language'] = $_CONF['path'] . 'language/'; $_CONF['rdf_file'] = $_CONF['path_html'] . 'backend/geeklog.rdf'; $_CONF['backup_path'] = $_CONF['path'] . 'backups/'; SITE SETTINGS $_CONF['site_name'] = 'ViperStrike.net'; $_CONF['site_slogan'] = 'Welcome to ViperStrike.net'; $_CONF['site_mail'] = 'admin@viperstrike.net'; $_CONF['site_url'] = 'www.viperstrike.net'; $_CONF['site_admin_url'] = $_CONF['path_html'] . 'admin'; $_CONF['theme'] = 'XSilver'; // default theme $_CONF['layout_url'] = $_CONF['path_html'] . '/layout/' . $_CONF['theme']; $_CONF['path_themes'] = $_CONF['path_html'] . '/layout/'; $_CONF['path_layout'] = $_CONF['path_themes'] . $_CONF['theme'] .'/'; $_CONF['allow_user_themes'] = 0; $_CONF['allow_user_photo'] = 1; // 1 = on, 0 = off...flag that allows users to upload self-photo i really appretiate your help. most of my problem is me not knowing any better Smile
 Quote

viperstrike

Anonymous
never mind I'm a tart I changed 'site_url' to 'path_html' I dont know why or when but I did. thanks again for your help Smile
 Quote

Anonymous

Anonymous
That was satisfying...
 Quote

All times are EDT. The time is now 11:37 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content