Welcome to Geeklog Tuesday, September 17 2019 @ 06:27 am EDT

Geeklog Forums

Upgrading 2.0 to 2.1 errors


Status: offline

Jerry Green

Forum User
Newbie
Registered: 18/01/14
Posts: 6
Location:Milton Keynes
I'm upgrading from 2.0 to 2.1 and after the database has been upgraded I get the following message:
An error has occurred:

(This text is only displayed to users in the group 'Root'Wink

256 - Template Error: set_root: professional is not a directory. @ /home/sites/historyandnews.co.uk/geeklog/system/classes/template.class.php line 992

Professional is my default layout. Can anyone help?

Status: offline

Jerry Green

Forum User
Newbie
Registered: 18/01/14
Posts: 6
Location:Milton Keynes
confused
I have restored from my backup and changed default and admin layout to denim before upgrading again. I am still getting the same message but with the word denim replacing professional. All layout folders are present and their content seems OK.

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/05
Posts: 1377
So it was working with 2.0.0 but not after the upgrade...

As far as you can tell did the upgrade finish?

Are your themes still stored under the layout directory?

Geeklog now comes with an emergency rescue tool located in the install directory. It allows you to enable/disable plugins along with changing a few key config values (like for directories). Maybe you should run this and check to make sure the directories are still correct.

Hope this helps

Tom

One of the Geeklog Core Developers.

Status: offline

Jerry Green

Forum User
Newbie
Registered: 18/01/14
Posts: 6
Location:Milton Keynes
So it was working with 2.0.0 but not after the upgrade... Yes it was working before upgrade.

As far as you can tell did the upgrade finish? At end of upgrade it went straight to the error message so I don't know whether it finished or not.


Are your themes still stored under the layout directory? Yes

Geeklog now comes with an emergency rescue tool located in the install directory. It allows you to enable/disable plugins along with changing a few key config values (like for directories). Maybe you should run this and check to make sure the directories are still correct. What is this tool called?

I will try the upgrade again when I know all about the above tool.

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/05
Posts: 1377
You shouldn't necessarily need to do the upgrade again. Put the install directory back and use the tool to see what the conf options are for the directory and if they are correct.

Also does the error.log file report anything?
One of the Geeklog Core Developers.

Status: offline

::Ben

Forum User
Full Member
Registered: 14/01/05
Posts: 1569
Location:la rochelle, France
The name of the rescue file is rescue.php in your public_html/admin/install folder.

Ben
I'm available to customise your themes or plugins for your Geeklog CMS

Status: offline

Jerry Green

Forum User
Newbie
Registered: 18/01/14
Posts: 6
Location:Milton Keynes
Thankyou Ben and Laugh. I will try the upgrade again when I can find the time.

All times are EDT. The time is now 06:27 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content