Welcome to Geeklog Monday, November 18 2019 @ 05:21 pm EST

Geeklog Forums

Templates Strip Links of URL- Adding Social Bookmarks


Adbox

Anonymous
working
I am adding social bookmarking to individual posts throught eh template storytext.thtml and the gl stystem strips out my urls that link the social bookmarking icon to the website.


well thats not true, it doesnt strip my link, it appends it to my base url, so my a href looks like this:
http://www.shredthenews.com/%E2%80%9Dhttp://del.icio.us/post?url=&title=%E2%80%9D

How can I get around this?

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Hard to say without seeing your template files (or the relevant parts of it).

bye, Dirk

adbox

Anonymous
The parsing, or whatever it is doing, is not taking place within my template file, but rather in a gl system file.

regardless here is a copy of my template code.
PHP Formatted Code

<div class="mpart">
    <span class="story-icons">  
       
        &nbsp;{email_icon}
       &nbsp;{print_icon}&nbsp;{pdf_icon}
       <a rel="nofollow" href=”http://del.icio.us/post?url=http://www.shredthenews.com/article.php?story={story_id}&title=”><img src="images/social/delicious.gif" title="Bookmark on del.icio.us"></a>

       <a  rel="nofollow" href=”http://digg.com/submit?phase=2&url=http://www.shredthenews.com/article.php?story={story_id}”><img src="images/social/digg.gif" title="Bookmark on Digg"></a>

       <a  rel="nofollow" href=”http://technorati.com/cosmos/search.html?url=http://www.shredthenews.com/article.php?story={story_id}”><img src="images/social/technorati.gif" title="Bookmark on Technorati"></a>

       <a  rel="nofollow" href=”http://reddit.com/submit?url=http://www.shredthenews.com/article.php?story={story_id}&title={story_title}” ><img src="images/social/reddit.gif" title="Bookmark on Reddit"></a>

       <a  rel="nofollow"  href=”http://www.google.com/bookmarks/mark?op=add&bkmk=http://www.shredthenews.com/article.php?story={story_id}&title={story_title}” ><img src="images/social/google.jpg" title="Bookmark on Google Bookmarks"></a>

    </span>
    <h2>{start_storylink_anchortag}{story_title}{end_storylink_anchortag}</h2>
    <h3>
        {story_date}<br />        {lang_contributed_by} {start_contributedby_anchortag}{contributedby_author}{end_contributedby_anchortag}<br />    </h3>
    <div class="story-body">
        {story_anchortag_and_image}{story_introtext}
    </div>
    <div class="story-footer">
        {edit_link}&nbsp;{page_selector}<br />        {readmore_link} {post_comment_link}
    </div>
    <div class="date">
        {start_comments_anchortag}{comments_with_count}{end_comments_anchortag} {start_trackbacks_anchortag}{trackbacks_with_count}{end_trackbacks_anchortag}
    </div>
</div>
 

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
The quote sign after the href= doesn't look like a regular quote. It's some Unicode character that only looks like one ...

bye, Dirk

adbox

Anonymous
you were right, it was those strange quotation marks that were causing all the problems. everything works great now thank you dirk

All times are EST. The time is now 05:21 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content