Welcome to Geeklog Sunday, September 15 2019 @ 06:06 pm EDT

Geeklog Forums

search error


Status: offline

muadmz

Forum User
Chatty
Registered: 05/03/05
Posts: 51
Im getting the following error when trying using search:



Template Error: set_root: /hsphere/local/home/mal/mysite.org//hsphere/local/home/mal/mysite.org/layout/professional is not a directory.
Halted.


Anyone know what this means and how I could fix this?


Status: offline

vadertech

Forum User
Full Member
Registered: 26/05/03
Posts: 329
and speaking of search...It's a pretty nifty tool.
GeekLog Hosting, Installations and Upgrades - WWW.AWEHOST.COM - Hosting starts @ only $4.95/mo.

Status: offline

machinari

Forum User
Full Member
Registered: 22/03/04
Posts: 1512
yes yes, the search will reveal the typical fix for the "template error", which involves missing template files, but that fix won't help you. Your $_CONF['path_html'] seems to be messed up unless you've edited your $_CONF['path_themes'], which you shouldn't have needed to on a typical install.

Status: offline

muadmz

Forum User
Chatty
Registered: 05/03/05
Posts: 51
where can i edit the $_CONF['path_themes'] ? I dont remember editing this. But I can see that my location is comming up two times.

Tks

Status: offline

machinari

Forum User
Full Member
Registered: 22/03/04
Posts: 1512
all your paths are defined in config.php

Status: offline

muadmz

Forum User
Chatty
Registered: 05/03/05
Posts: 51
ok in my config.php, the path themes looks like this:

// you shouldn't need to edit the following
$_CONF['layout_url'] = $_CONF['site_url'] . '/layout/' . $_CONF['theme'];
$_CONF['path_themes'] = $_CONF['path_html'] . 'layout/';
$_CONF['path_layout'] = $_CONF['path_themes'] . $_CONF['theme'] . '/';


So why do I get this error than:

Template Error: set_root: /hsphere/local/home/mal/mysite.org//hsphere/local/home/mal/mysite.org/layout/professional is not a directory.
Halted.


Im sorry, but I do not understand this properly.

Status: offline

lokki

Forum User
Chatty
Registered: 19/03/05
Posts: 59
What is your Geeklog version?
And what are your $_CONF["path"] and $_CONF["path_html"] set to?

Status: offline

muadmz

Forum User
Chatty
Registered: 05/03/05
Posts: 51
ok my $_CONF['path'] is:

$_CONF['path'] = '/hsphere/local/home/mal/mysite.org/';


and my $_CONF['path_html'] is:

$_CONF['path_html'] = $_CONF['path'] . 'public_html/';



I have tried just putting a / for the first one. But when I do that, the site gets an error as i need the first path to point to the config.php file.


Oh and Im using: Geeklog 1.3

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Something doesn't match up here. If you left $_CONF['path_html'] at its default value, then the error you quoted above should include "public_html" somewhere in the path - but it doesn't.

Are you sure you've quoted from the correct config.php file, i.e. the one that's actually on your server?

bye, Dirk

Status: offline

muadmz

Forum User
Chatty
Registered: 05/03/05
Posts: 51
yeah the main config.php file on the webserver. I take this config.php file out, the main site gets errors when trying to access it.

below is the whole section of the code but I have changed the domain to mysite.org as you can see:


// +---------------------------------------------------------------------------+
// | (2) Paths |
// +---------------------------------------------------------------------------+

// Note for Windows users: It's safe to use the forward slash '/' instead of
// the backslash '' in paths. Make sure each path starts with a drive letter!

// This should point to the directory where your config.php file resides.
$_CONF['path'] = '/hsphere/local/home/mal/mysite.org/'; // should end in a slash

// You only need to change this if you moved or renamed the public_html
// directory. In that case, you should specify the complete path to the
// directory (i.e. without the $_CONF['path']) like this:
// $_CONF['path_html'] = '/path/to/your/public_html/';
$_CONF['path_html'] = $_CONF['path'] . 'public_html/';



hope u can help

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Quote by muadmz: below is the whole section of the code but I have changed the domain to mysite.org as you can see:

This looks perfectly okay.

So the Professional theme would be in /hsphere/local/home/mal/mysite.org/public_html/layout/professional/ - and that's where Geeklog would look for it.

With those settings, you shouldn't get the error message you quoted above. Are you sure you uploaded the correct config.php (or that you're quoting from the config.php that's actually on your server)?

bye, Dirk

Status: offline

muadmz

Forum User
Chatty
Registered: 05/03/05
Posts: 51
confused
Im quoting from the config.php that is actually on the server. I downloaded it to my pc and double checked it aswell. What I dont understand is why does the path come up twice in the error?

tks


All times are EDT. The time is now 06:06 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content