Welcome to Geeklog Sunday, October 22 2017 @ 10:33 pm EDT


Status: offline

Chrispcritters

Forum User
Chatty
Registered: 11/05/2005
Posts: 49
Location:Tustin, CA
Reguardless of how many people are on the site the Who's Online only shows 1 guest user. Any suggestions as to what the problem is? I went to the site from machines on several IP addresses all at the same time and it still shows only 1 guest user.

Chrispcritters

Anonymous
OK, not sure if this is related or no, but the polls module does not seem to be working correctly either. As soon as one person votes is shows only results for anyone who looks at it. Nobody else can vote!

Suggestions?


Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/2002
Posts: 13073
Location:Stuttgart, Germany
As for the polls, see How do the polls work?

bye, Dirk

Status: offline

Chrispcritters

Forum User
Chatty
Registered: 11/05/2005
Posts: 49
Location:Tustin, CA
Interesting. I created a poll. Someone else took the pool. Now it shows be the results as if I was the one who had responded to it.

Suggestions?

www.whatismyipaddress.com

Status: offline

Chrispcritters

Forum User
Chatty
Registered: 11/05/2005
Posts: 49
Location:Tustin, CA
Turns out to possible be a server configuration issue with Mac OS X 10.3 Server.

For some reason $_SERVER['REMOTE_ADDR'] always returns the server's IP address not the remote user's IP address. I just ended up replacing all the $_SERVER['REMOTE_ADDR'] with $_SERVER['HTTP_PC_REMOTE_ADDR'] is it seems to have resolved the issues.

Now I just need the make the needed changes to the BAN plugin to do the same...

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/2002
Posts: 13073
Location:Stuttgart, Germany

All times are EDT. The time is now 10:33 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content