Welcome to Geeklog Monday, December 09 2019 @ 02:08 pm EST

Geeklog Forums

Forum 2.2RC1 + GL 1.3.8 and custom_registration


Status: offline

destr0yr

Forum User
Full Member
Registered: 06/07/02
Posts: 324
artistic
i made a post @ www.langfamily.ca, however, i was hopping someone could help here as well... here\'s the post: OK... tonight I had to take an extra celexa cuzz i was wiggen out... i have a problem again. to the point: have gl 1.3.8 - it works have forum 2.2 RC1 - it works problem = when i display any users profile (/users.php?mode=profile&uid=2), the extra added info (msn,yim,icq,etc) does not showup. I have quadruple checked that i updated my layout w/the new users/profile.thtml and preferences/profile.thtml. also, in GL\'s config.php there is \"$_CONF[\'custom_registration\'] = false;\" i don\'t know exactly what it\'s for, so i made it true and got the following: (web based) 1064: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near \'WHERE gl_users.uid = 2 AND .uid = 2\' at line 1 and error.log: Mon Jul 21 03:13:46 2003 - 1064: You have an error in your SQL syntax.Check the manual that corresponds to your MySQL server version for the right syntax to use near \'WHERE gl_users.uid = 2 AND .uid = 2\' at line 1 SQL in question: SELECT * FROM gl_users, WHERE gl_users.uid = 2 AND .uid = 2 from the looks of it, it\'s missing the table name for the \"AND .uid\" ? i also travelled over to squatty.com and when you check a profile on the users there it does not display the extra info either... i assume Danny left the custom_registration @ false... so i guess my questions go like so: 1. did i do something wrong w/the extra info for it not to show up? 2. is the custom_registration related to making this work and should it be true/false? here
-- destr0yr "I love deadlines. I like the whooshing sound they make as they fly by." -- Douglas Adams
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Quote by destr0yr: 2. is the custom_registration related to making this work and should it be true/false?
To answer that part: The custom registration is an unrelated new feature in Geeklog that allows you to create your own (extended) registration form when new users register with your site. An example is included in lib-custom.php, but requires that you create a new table first. So when you activate the feature but haven\'t created the table, you\'ll get the SQL errors you quoted. Again, this has nothing to do with the extensions to the user profile, so you should set it to false again. bye, Dirk
 Quote

Status: offline

destr0yr

Forum User
Full Member
Registered: 06/07/02
Posts: 324
Thaks Dirk. Thats the definitive answer i was looking for.
-- destr0yr "I love deadlines. I like the whooshing sound they make as they fly by." -- Douglas Adams
 Quote

All times are EST. The time is now 02:08 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content