Welcome to Geeklog Sunday, August 25 2019 @ 02:01 am EDT

Geeklog Forums

stats plugin: gethostbyaddr Address is not a valid IPv4 or IPv6 ??


Status: offline

destr0yr

Forum User
Full Member
Registered: 06/07/02
Posts: 324
following error:



PHP Formatted Code
[02-Oct-2003 09:00:03] PHP Warning:  gethostbyaddr(): Address is not a valid IPv4 or IPv6 address in /home/okanagan/plugins/stats/functions.inc on line 341




any suggestions on how to fix it?



line 340:

PHP Formatted Code
<br />. "', host='" . gethostbyaddr($REMOTE_ADDR)<br />


-- destr0yr "I love deadlines. I like the whooshing sound they make as they fly by." -- Douglas Adams

Status: offline

tomw

Forum User
Full Member
Registered: 12/08/02
Posts: 300
I have seen this occasionally in the block code when someone has some off the wall address as the referer. The only way I know to fix it is to go into the database and delete the offending entry. If you have the new version you can go into config.php and turn off the referer section for a day. After that it will not bother you until you try to get some reports.

TomW

Status: offline

lfalfa

Forum User
Newbie
Registered: 01/04/04
Posts: 12
I hit this problem because of the daily digest script. I fixed it by going into the visitor stats admin page and adding the following to the list of pages not captured:

/path/to/geeklog/emailgeeklogstories

Replace "/path/to/geeklog" with the actual file path to the location of your geeklog's emailgeeklogstories script.

Status: offline

ajzz

Forum User
Regular Poster
Registered: 19/01/05
Posts: 113
FYI: Had this issue during upgrade of Gallery to 1.5rc2 (on GL 1.3.11)... by default the gallery config script turns off register_globals using the automatically created local .htaccess file. (Manually turning on register_globals in the gallery config.php eliminated the problem.)

Perhaps mine and the previous cases in this thread have in common the fact that somehow the ip address is not available to the script despite being globally available?

Status: offline

sashaw54

Forum User
Newbie
Registered: 13/12/05
Posts: 1
Location:Pasadena, CA
I am running GL version 1.3.8 on an X-Server with OSX 10.2.8. It was running fine until the Apple Security Update 2005-001 was installed yesterday. The update 'fixes' PHP... now this error message appears on each web page. Also, cannot get past the first page of any item. I have tried to get to the STATS Admin page via the Plugins, and I get the first window, but cannot open it, by clicking on the number, so that the STATS plugin can be turned off. If I go to the Admin Home | Visitors Stats, then I get the button 'turn capture off', but nothing happens. Is there another way to shut off the STATS plugin? I inherited this, and don't drive well in the Apple/Linux/PHP world, so please be gentle :-)

Status: offline

asmaloney

Forum User
Full Member
Registered: 08/02/04
Posts: 214
Quote by sashaw54: Is there another way to shut off the STATS plugin? I inherited this, and don't drive well in the Apple/Linux/PHP world, so please be gentle :-)


If you can't disable the plugin through the interface, you can change the plugins table in the database directly. In the gl_plugins table, find the entry with 'pi_name' stats and change 'pi_enabled' from 1 to 0.

- Andy

Me

Anonymous
add @ in front of gethostby..

Chris

Anonymous
awake
Quote by: Me

add @ in front of gethostby..



Worked perfectly, thanks Smile

All times are EDT. The time is now 02:01 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content