Welcome to Geeklog Wednesday, July 17 2019 @ 02:47 am EDT

Geeklog Forums

Internal Server Error in Links.php section


Sunnymonkey

Anonymous
awake
My geeklog site is setup. no problems. works great.
The ONLY thing that is not work is the links.php section

I can see all the links and categories etc, however when you click on any of the links you get an internal server error.

http://dashboardmonkey.com/geek/portal.php/link/20050204202702723

The same thing happens with the "Friendly url system" turned off, so I know it is not that.

I have run the test script and all permissions are ok

And the rest of the site runs fine.

Any ideas people?

Thanks
Dave

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Do you have access to the server's error_log file (not Geeklog's error.log? If so, check that for hints.

bye, Dirk

Status: offline

r_f_o_t

Forum User
Full Member
Registered: 30/07/03
Posts: 241
Location:Illinois
We had the same problem. As a quick fix, I replaced the public_html/portal.php file with the one from either GL 1.3.9 or GL 1.3.8. I have not had time to investigate further or file a bug report yet.

I'm assuming that my older php (4.2.2) does not like the new file.

You can get the older file from the download section here.

HTH,

Chuck
Too many hands on my time.

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Quote by r_f_o_t: As a quick fix, I replaced the public_html/portal.php file with the one from either GL 1.3.9 or GL 1.3.8. I have not had time to investigate further or file a bug report yet.

I can tell you the differences:
  1. The new one supports url_rewrite - but that apparently isn't the problem
  2. The new one uses header ('Location: ...'); to do the redirect while the old one uses a meta refresh

No idea why the header redirect would cause an internal server error, though.

bye, Dirk

Status: offline

r_f_o_t

Forum User
Full Member
Registered: 30/07/03
Posts: 241
Location:Illinois
Quote by Dirk:No idea why the header redirect would cause an internal server error, though.


Unless it has to do with being stuck on really old version of apache (1.3.single digit)?

Chuck
Too many hands on my time.

All times are EDT. The time is now 02:47 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content