Welcome to Geeklog Thursday, October 29 2020 @ 07:42 pm EDT

Geeklog Forums

DB Backups..


Anonymous

Anonymous
When i try to do a backup DB i get this error: Warning: OpenDir: No such file or directory (errno 2) in /usr2/hsphere/home/sscentra/black.sscentral.com/admin/database.php on line 73 Database back up was successful. But it wasn't successful... Anyone know what i need to do to fix this? Thanks
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Hmm, that shouldn't happen ... Please check that you even have a "backups" directory (it is in the tarball, but it is empty and sometimes isn't extracted or uploaded because of that) and that $_CONF['backup_path'] in config.php points to it. bye, Dirk
 Quote

Status: offline

efarmboy

Forum User
Moderator
Registered: 26/02/02
Posts: 147
Can you also clarify which GL version you are using. This looks like it's an error message from the pre 1.3.6 version of GL. Blaine
 Quote

Anonymous

Anonymous
Im using 1.3.5sr2 I got the error to go away but now it says " Database back up was successful. " but i still have "No backups in the system" Thanks again
 Quote

Status: offline

efarmboy

Forum User
Moderator
Registered: 26/02/02
Posts: 147
This is why I was asking which GL version you are using. GL 1.3.6 has more error checking to catch these errors. In pre 1.3.6, if your path to mysqldump is incorrect, it was not reporting it. the dump was not executing and it was assumed to be sucessful. Check the setting for: $_DB_mysqldump_path in config.php Blaine
 Quote

Status: offline

Dirk

Site Admin
Admin
Registered: 12/01/02
Posts: 13073
Location:Stuttgart, Germany
Yeah, 1.3.5 has very poor error handling for backups (this has been improved in 1.3.6). Make sure your backups directory is writeable - chmod it to 775 first and try 777 if that doesn't help. bye, Dirk
 Quote

Status: offline

dwelch

Forum User
Newbie
Registered: 17/05/03
Posts: 6
I found that having a $ in my database password was problematic. Fixed that, and my backups started working. -- PhoneBoy
 Quote

All times are EDT. The time is now 07:42 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content