Welcome to Geeklog Monday, November 19 2018 @ 02:47 pm EST

Geeklog v2.2.0

  • Contributed by:
  • Views: 1,641
Announcements

Geeklog v2.2.0 is now available for download and is the recommended version for all production sites.

New features and fixes in this version include:

  • [Feature] Added Uikit 3 framework and new theme Denim_Three
  • [Feature] Blocks can now appear in more than just the left or right column. Block Locations can now be added by plugins and themes
  • [Feature] New CSS and JS processor to Minify and combine files
  • [Feature] ReCaptcha Plugin now included with the Geeklog Install
  • [Feature] ReCaptcha Plugin now supports Invisible Captcha
  • [Feature] New Passwords must contain a minimum of 8 characters and have at least 1 letter and 1 number
  • [Feature] Two Factor Authentication is available for user accounts
  • [Feature] You can now require all user accounts to have a verified email address (including remote accounts)
  • [Feature] New User Statuses Added (Locked, New Email Required, New Password Required)
  • [Feature] Akismet module now included with the SPAM-X plugin
  • [Feature] Built in Demo Mode
  • [Bug] Fixed After token expired re-authentication returns to a blank page once Authentication is successful
  • [Bug] Fixed Switch Language Block (and COM_getLanguageFromURL) to work on a topic page

... as well as a lot of other improvements and bug fixes. The complete list can be found on Github and in the history text file located in the docs directory of this release.

Note: A bug was found in the installer and Geeklog v2.2.0 that causes an error on servers with PHP v5.3 installed. Therefore for Geeklog v2.2.0 you should consider the minimum PHP version to be v5.5 (note added July 19, 2018)

Note: Make sure your 3rd party Geeklog plugins are updated to the latest version as they are required to use the function COM_createHTMLDocument. This replaces the functions COM_siteHeader and COM_siteFooter. If you are unsure if a plugin supports Geeklog v2.2.0 then either disable it before the Geeklog Upgrade, or uninstall the plugin.

Remember if you would like to chat with any of the community one of the best place to reach us is on Gitter in the Geeklog room.