Welcome to Geeklog Saturday, November 17 2018 @ 12:19 am EST

Geeklog Forums

Error 404 with URL Rewrite


Status: offline

alb3rt

Forum User
Chatty
Registered: 30/10/06
Posts: 52
Location:Mexico City
Hi guys,

When I am logged in and using "url rewrite" many times I get a 404 error, as an anonymous user the error never appears. If I wait a bit and refresh the page loads correctly.



Any idea why it happens?

Thanking you in advance,
D Web Studio - www.d-webstudio.net

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/05
Posts: 1316
Hmm not sure. If it works for anonymous user it should work as a logged in user.

If a user doesn't have access to a page (depending what it is) a 404 could be returned but since an anonymous user has access all should.

You could also create issues by accident by adding similar rules in the Geeklog Admin URL Routing list but again this shouldn't be your issue since it works for anonymous users.

In the Geeklog Configuration I would goto url rewrite config option and read the docs (or I guess you can access it here (https://www.geeklog.net/docs/english/config.html#url-rewrite) on Geeklog.net just to make sure you have everything setup correctly (including the htaccess file, etc...)

One of the Geeklog Core Developers.

All times are EST. The time is now 12:19 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content