Welcome to Geeklog Saturday, March 24 2018 @ 09:44 pm EDT

Status: offline


Forum User
Registered: 06/12/2017
Posts: 22
lib-common.php is hacked to modify my website long years ago.
Should I keep hacking code with the upgraded geeklog to the latest version?
Geeklog core files such as lib-common.php is not object-oriented so it seems difficult/nonsense to extends the original function. It may be possible to copy full source of it to another file and override the core functions, but it is almost same as hacking the original.
Any advice?

Status: offline


Site Admin
Registered: 27/09/2005
Posts: 1262
It's hard to say without seeing what has been changed.

I would do what ever makes it easiest to upgrade your site in the future.

Maybe some of your changes are not needed anymore as a lot has changed since Geeklog 1.4.1

One of the Geeklog Core Developers.

All times are EDT. The time is now 09:44 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content