Welcome to Geeklog Friday, October 20 2017 @ 09:18 pm EDT


Carl

Anonymous
Hello! I was trying to update from 1.7.1rs1 to 2.1.1 and it's asking me to save the db-config.php file but I only have a config.php file. Any chance how I solve this problem? Many thanks.

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/2005
Posts: 1232
The db-config.php file is located in the same directory as the plugins directory and public_html directory are located (in a typical install).


One of the Geeklog Core Developers.

Carl

Anonymous
Weird I didnt think this post worked so I made another one.

There is only a config.php and no db-config.php file.

Usually when I update something I don't have to copy and restore any files. I just click update and it updates.

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/2005
Posts: 1232
Geeklog 2.1.1 download comes with that file. Are you sure you copied over all the files?
One of the Geeklog Core Developers.

Carl

Anonymous
Thanks Laugh. My only other question is I tried to modify the styles.css file and removed the words underline and replaced with none, but I still have underlined links.

Do you know how to remove the underline links?

www.hvactechgroup.com


Thanks for the help sir!

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/2005
Posts: 1232
Sorry Carl I missed your reply.

You could add the following code to the bottom (has to be at the bottom) of the style.css file for the professional theme you are using like so:

PHP Formatted Code

a:hover, a:visited, a:link, a:active
{
    text-decoration: none;
}
 


The reason the underline is happening on links is because somewhere in the style.css file the style for links are set to

text-decoration: underline;

You could also search for these (probably multiple locations) and change underline to none.
One of the Geeklog Core Developers.

Carl

Anonymous
Thanks for the reply Laugh.

/public_html/layout/professional/style.css

I deleted that file to make sure I was working with the right one. My theme disappeared so I know this is the right file. I added the code you provided to the bottom, and even changed both instances of "underline" to say "none".

I still can't seem to get rid of the underlined links on my page at,

www.hvactechgroup.com

What's weird is before I updated Geeklog I was able to remove them by editing the style.css file.

Status: offline

::Ben

Forum User
Full Member
Registered: 14/01/2005
Posts: 1569
Location:la rochelle, France
Hi,

Try

PHP Formatted Code
a:hover, a:visited, a:link, a:active
{
    text-decoration: none !important;
}

I'm available to customise your themes or plugins for your Geeklog CMS

Carl

Anonymous
That worked. Thank you Ben.

All times are EDT. The time is now 09:18 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content