Welcome to Geeklog Saturday, October 21 2017 @ 09:47 am EDT


frawo

Anonymous
I can only use Denim theme, every time I try to change theme I get these errors:
An error has occurred:

(This text is only displayed to users in the group 'Root'Wink

E_WARNING(2) - preg_match(): Empty regular expression @ /storage/content/x/xx/xx.net/xx_logg/system/classes/config.class.php line 1867


Call Stack


#

Function

File

Line

1 preg_match /storage/content/x/xx/xx.net/xxlogg/system/classes/config.class.php 1867
2 _validates /storage/content/x/xx/xx.net/xxlogg/system/classes/config.class.php 1606
3 updateConfig /storage/content/x/xx/xxt.net/public_html/admin/configuration.php 609


Frank

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/2005
Posts: 1232
What theme are you changing it too?
One of the Geeklog Core Developers.

frawo

Anonymous
Modern Curve, Professional and Cool-master.

it all started after upgrading from version 2.1.0 to 2.1.1

When I try db-backup I get this:
Feil sti (wrong path) eller mysqldump er ikke kjørbar.
Sjekk $_DB_mysqldump_path definisjonen i config.php.
Variabelen er nå satt til: /usr/bin/mysqldump



Frank

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/2005
Posts: 1232
Is anything in the error log?

Could you change themes before 2.1.1?
One of the Geeklog Core Developers.

frawo

Anonymous
Error log (not sure where to find) , one said a lot about could not "unserialize".

G2Bridge:G2_path
Tue Jan 5 17:26:20 2016 - 217.170.198.8 - Unable to unserialize s:60:"/storage/content/s1fre/s1fre/xxx.net/public_html/G2/gallery2";

I could change themes pre 2.1.0


Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/2005
Posts: 1232
The error.log file is located in the logs directory.

Did you update all the files including the ones for the themes (Mondern Curve, etc..) when you upgraded from Geeklog 2.1.0 to 2.1.1?

Templates did change so if you didn't this may be causing you some problems. I would test only with the themes which come with Geeklog. Your Cool-Master theme will need updating.

https://www.geeklog.net/docs/english/theme.html#changes

It may also be caused by 3rd party plugins (like G2Bridge). To narrow down the problem try disabling those an then changing the theme to see if it fixes it.


One of the Geeklog Core Developers.

frawo

Anonymous
All themes was updated.

Tried to delete 3rd party plugins from the panel, no success. So I deleted 4 plugins (GeekBook, G2Bridge among those) from the plugin folder by ftp-client. And that was stupid Smile

Error:
E_WARNING(2) - require_once(/storage/content85/985/xx.net/xx_logg/plugins/GeekBook/functions.inc): failed to open stream: No such file or directory @ /storage/content/5/985/xx.net/public_html/lib-common.php line 9051

Any other places to delete plugins? In the database?

Frank

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/2005
Posts: 1232
You will have to put those files back as Geeklog assumes they are still installed.

You can disable the plugins from the plugin administrator with just a click, no need to uninstall them unless one or more of them is the problem.

Tom
One of the Geeklog Core Developers.

All times are EDT. The time is now 09:47 am.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content