Welcome to Geeklog Friday, August 17 2018 @ 12:32 pm EDT

Geeklog Forums

Downloads plugin breaks when multiple languages support is enabled.


Status: offline

syco

Forum User
Junior
Registered: 24/04/04
Posts: 15
Location:Liège, Belgium
confused
Hi all!

I have a problem with geeklog 2.1.0 and downloads 1.2.0: When i enable multi-language mode for my site the plugin displays 0 files (no files found message). The files are there but don't show up and neither do the downloads categories.

I managed to list them by commenting line 668 of the plugin's index.php, the files show up but the count is stil 0 and categories don't show up.

I just don't understand how this can be related to the multi-language mode but it really seems to be happening there: if i disable it the plugin works fine.

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/05
Posts: 1299
I haven't used the downloads plugin so what you describe may be a bug but I have a feeling that you need to recreate each category for each language.

This is how Geeklog works for Topics when Multilanguage support is enabled.

Tom
One of the Geeklog Core Developers.

Status: offline

syco

Forum User
Junior
Registered: 24/04/04
Posts: 15
Location:Liège, Belgium
happy
Yes !

That was it! Works perfect now. At first i was afraid i would have to duplicate all the files since the file_id changes, but no it'just fine

thanks a lot Smile

All times are EDT. The time is now 12:32 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content