Welcome to Geeklog Tuesday, November 21 2017 @ 09:05 pm EST


Status: offline

thatlinuxbox

Forum User
Newbie
Registered: 04/09/2013
Posts: 14
Location:Gainesville, FL
I have Facebook, Twitter, and Google OAuth enabled on my site:

http://thatlinuxbox.com/blog/

All were working fine previously.

Today I notice that I cannot log in with Google anymore.

My Geeklog error log:

Sat 16 Aug 2014 15:19:11 EDT - 24.170.201.138 - 1064: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'Wink' at line 1 in .../system/lib-user.php:302. SQL in question: INSERT INTO gl_group_assignments (ug_main_grp_id, ug_uid) VALUES (13, )

Sat 16 Aug 2014 15:19:11 EDT - 24.170.201.138 - E_USER_ERROR(256) - An SQL error has occurred. Please see error.log for details. @ .../system/databases/mysqli.class.php line 279

I tried deleted the Google user, did not change the behavior or error log lines.

I am not sure if this matters, but I have successfully logged in with my Facebook and Twitter accounts (and Google account), all of which are registered with the same email address.

Thanks,
- Dan Stoner

ironmax

Anonymous
Dan,

I just logged into your site, with my Google user name with no issues. Give it another try. If it still doesn't work, then we'll have to look into it further.

Michael

Status: offline

thatlinuxbox

Forum User
Newbie
Registered: 04/09/2013
Posts: 14
Location:Gainesville, FL
Yes, working now. Thanks for testing.

Strangeness!

- Dan Stoner




Status: offline

thatlinuxbox

Forum User
Newbie
Registered: 04/09/2013
Posts: 14
Location:Gainesville, FL
My problem has returned.

I wonder if it is a token timeout of some kind?

I had been logged in and editing a story this morning and when I came back from lunch my "session" had expired (I was directed to the Geeklog "Authentication Required" page when I tried to edit the story again). That page, BTW does not show any OAuth buttons in the body.

I clicked on my Google OAuth button in my sidebar and then received the "Unfortunately, an error has occurred rendering this page. Please try again later." message.

The error log lines (it seems that ug_uid is empty which is why the SQL query is failing):

Mon 18 Aug 2014 14:17:39 EDT - 128.227.127.75 - 1064: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'Wink' at line 1 in .../system/lib-user.php:302. SQL in question: INSERT INTO gl_group_assignments (ug_main_grp_id, ug_uid) VALUES (13, )
Mon 18 Aug 2014 14:17:39 EDT - 128.227.127.75 - E_USER_ERROR(256) - An SQL error has occurred. Please see error.log for details. @ .../system/databases/mysqli.class.php line 279


- Dan Stoner

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/2005
Posts: 1240
Put a bug report in for the error.

I knew about the Geeklog "Authentication Required" page not having the OAuth buttons. The issue there I believe deals with the fact that there is multiple redirects so the Geeklog Authentication required page couldn't handle that. Still we should either fix the problem (if possible) or show a different page stating something like the story couldn't be saved due to your oauth session timed out.


One of the Geeklog Core Developers.

Status: offline

thatlinuxbox

Forum User
Newbie
Registered: 04/09/2013
Posts: 14
Location:Gainesville, FL
Bug report submitted.

http://project.geeklog.net/tracking/view.php?id=1779

All times are EST. The time is now 09:05 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content