Welcome to Geeklog Monday, June 24 2019 @ 06:03 pm EDT

Geeklog Forums

Advanced editor and IE11


Status: offline

casper

Forum User
Full Member
Registered: 11/02/04
Posts: 142
Location:Skien, Norway
Hmm.. Over the weekend users got their internet exploder updated to ver 11.
Goes a bit slow here in Norway Cool
And then the advanced editor disappeared.

Using the developer tools (F12) and change document mode to 9 brings back the editor.

Checked Opera an Chrome, the editor shows, but only in one of the two areas in article editor...

Anyone got a tip on how to fix this?

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/05
Posts: 1352
Hmmm you are right, The Advanced Editor in IE 11 doesn't work. We have been having issues with the FCKEditor since IE 10 but it still worked for the most part (it works fine in Firefox and Chrome).

FCKEditor is not being worked on anymore by the developers. They are concentrating their efforts on their updated version called CKEditor (slight name change). Geeklog 2.1.0 uses the CKEditor.

Currently if you want to use the FCKEditor you will need to use one of the other browsers... sorry.

Tom
One of the Geeklog Core Developers.

Status: offline

casper

Forum User
Full Member
Registered: 11/02/04
Posts: 142
Location:Skien, Norway
Thats ok, but can I do anything with the issue in chrome and opera where the article editor only have the advanced editor in one of the two texareas?

Status: offline

::Ben

Forum User
Full Member
Registered: 14/01/05
Posts: 1569
Location:la rochelle, France
I tested Chrome 31 on the demo site. The two textareas are present.

Do you use a custom template?

Ben
I'm available to customise your themes or plugins for your Geeklog CMS

Status: offline

casper

Forum User
Full Member
Registered: 11/02/04
Posts: 142
Location:Skien, Norway
Hi Ben,

I tested the demosite too, and it was fine. I Still use 1.8.2
Yes, I use a custom template, but dropped in the professional again to test.
Still the same problem... And as far as I can remember the admin templates is untouched, only site-wide css is changed.
But discovered something strange:
If I rightclicked the link "contribute" and opened it in a new tab, and waited until the tab was fully loaded before switch, both texareas had the editor.
This was the same for both stock and custom template.

This is beyond my competence, will be waiting for a genie to pass by... Question Exclamation

Status: offline

::Ben

Forum User
Full Member
Registered: 14/01/05
Posts: 1569
Location:la rochelle, France
This seems to be a javascript issue like a loading not complete. Can you provide me a link to have a look ?

Ben
I'm available to customise your themes or plugins for your Geeklog CMS

Status: offline

casper

Forum User
Full Member
Registered: 11/02/04
Posts: 142
Location:Skien, Norway
Thats nice of you Ben.
Will send you a mail with link and login.

Status: offline

::Ben

Forum User
Full Member
Registered: 14/01/05
Posts: 1569
Location:la rochelle, France
O, your site, the console displays
PHP Formatted Code
Uncaught SecurityError: Blocked a frame with origin "http://folketsbypakke.no" from accessing a frame with origin "http://static.ak.facebook.com". The frame being accessed set "document.domain" to "facebook.com", but the frame requesting access did not. Both must set "document.domain" to the same value to allow access.

Maybe an issue with code integration from facebook.

Ben
I'm available to customise your themes or plugins for your Geeklog CMS

Status: offline

casper

Forum User
Full Member
Registered: 11/02/04
Posts: 142
Location:Skien, Norway
Thanks Ben... Code referenced https, site is http it claimed.
But making sure both sites was http did not solve it.
The frame is for the facebook-feed, and it collides with some other scripts.
Some search showed results for user with the same problems regarding fckeditor.

Scrapped the use of script for facebook, just uses an iframe insted untill..

Now fck works in opera and chrome, and thats how it stays until I upgrade GL.
Thanks for your effort!

Status: offline

suprsidr

Forum User
Full Member
Registered: 29/12/04
Posts: 555
Location:Champaign, Illinois
You can force IE into IE9 mode which works:
PHP Formatted Code
<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE9" />

FlashYourWeb and Your Gallery with the E2 XML Media Player for Gallery2 - http://www.flashyourweb.com

Status: offline

casper

Forum User
Full Member
Registered: 11/02/04
Posts: 142
Location:Skien, Norway
Thanks supersidr!
A ok fix until the whole site is updated Smile

Status: offline

casper

Forum User
Full Member
Registered: 11/02/04
Posts: 142
Location:Skien, Norway
Now the holidays are over, I found some time to dig into this.
An update in the file /public_html/fckeditor/editor/js/fckeditorcode_gecko.js
at line 36 fixed the issue.
Now the advanced editor appears even if using Chrome or IE.

Replace:
PHP Formatted Code

FCKTools.FixDocumentParentWindow=function(A){if (A.document) A.document.parentWindow=A;for (var i=0;i<A.frames.length;i++) FCKTools.FixDocumentParentWindow(A.frames[i]);};
 

with:
PHP Formatted Code

FCKTools.FixDocumentParentWindow=function(A){try{if (A.document) A.document.parentWindow=A;} catch(e){};for (var i=0;i<A.frames.length;i++) FCKTools.FixDocumentParentWindow(A.frames[i]);};
 

Status: offline

Laugh

Site Admin
Admin
Registered: 27/09/05
Posts: 1352
Any idea on what the fix does?

I can confirm it works in Chrome but I seem to be still having an issue in IE11. (using an unreleased version of Geeklog 2.1.0)
One of the Geeklog Core Developers.

Status: offline

casper

Forum User
Full Member
Registered: 11/02/04
Posts: 142
Location:Skien, Norway
Oh... And the 2.1 uses the upgraded version CKeditor?

To fix IE only thing I have tried is the tip I got here:
PHP Formatted Code
<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE9" />


Not quite sure of exactly how this works, but as of V 30 of Chrome it was implemented some securityfeature regarding x-scripting in frames.
This made both googles own scripts to stop, and as for me facebooks killed the editor..
Google has since then fixed some of the scripts but not all.

AFAIK the problem with IE was fixed in a new version of CKeditor, I still run 1.8.2 with FCKeditor. But it looks like thats not correct as you still find the issue?

All times are EDT. The time is now 06:03 pm.

  • Normal Topic
  • Sticky Topic
  • Locked Topic
  • New Post
  • Sticky Topic W/ New Post
  • Locked Topic W/ New Post
  •  View Anonymous Posts
  •  Able to post
  •  Filtered HTML Allowed
  •  Censored Content