Topics

User Functions

Events

There are no upcoming events

What's New

Stories last 2 weeks

No new stories

Comments last 2 weeks

No new comments

Trackbacks last 2 weeks

No new trackback comments

Links last 2 weeks

No recent new links

NEW FILES last 14 days

No new files

Welcome to Geeklog Wednesday, April 23 2014 @ 01:03 PM EDT


 Forum Index > Support > General Geeklog Support New Topic Post Reply
 There is a very big bug about Chinese Article on Geeklog 1.8.1 and 2.0.0rc1
First | Previous | 1 2| Next | Last
   
chunxiao
 01/08/13 08:12AM (Read 1924 times)  
+----
Newbie

Status: offline


Registered: 01/08/13
Posts: 13
I am from China.I find that There is a very big bug about Chinese Article on Geeklog 1.8.1 and 2.0.0rc1.
When I write a Chinese Article,my geeklog sites When I finished writing the Chinese article, and then published on my website.Articles become "????????????". I installed the website, check the "UTF-8". Partner has to try Geeklog 1.8.1 and 2.0.0rc1, re-install the site twice I found the MySQL database table article, those Chinese article is displayed as "????????????" I try to comment on the Japanese, the Japanese lettersChinese and Japanese UTF-8 language file for???????. "My Geeklog site I think it should Geeklog program. previous partners seem to install Geeklog 1.7.x, there is no suchproblems.
I hope you will be able to fix this problem is very urgent.

The Geeklog Chinese enthusiast community website(http://cn.chunxiao.me) My personally official blog: http://www.chunxiao.me
 
Profile Email
 Quote
chunxiao
 01/08/13 08:22AM  
+----
Newbie

Status: offline


Registered: 01/08/13
Posts: 13
I mentioned Forum Geeklog official website, and hair stomach again the Chinese Post, is also showing a lot of "??????????????"?I come from China, I wrote in the January 8, 2013 at 21:00 of the problem posts.?

The Geeklog Chinese enthusiast community website(http://cn.chunxiao.me) My personally official blog: http://www.chunxiao.me
 
Profile Email
 Quote
chunxiao
 01/08/13 08:32AM  
+----
Newbie

Status: offline


Registered: 01/08/13
Posts: 13
My personal website?http://www.chunxiao.me?owered by wordpress?
http://cn.chunxiao.me(powered by Geeklog )

I support Geeklog ?Welcome to contact me

The Geeklog Chinese enthusiast community website(http://cn.chunxiao.me) My personally official blog: http://www.chunxiao.me
 
Profile Email
 Quote
Laugh
 01/08/13 11:18AM  
AAAAA
Admin

Status: offline


Registered: 09/27/05
Posts: 998
Your site displays Chinese characters fine so it is probably your database.

Is your database UTF-8?

Also make sure your geeklog tables are UTF-8. I believe a bug has been reported that on some installs they are not.

Tom

 
Profile Email Website
 Quote
chunxiao
 01/08/13 11:52PM  
+----
Newbie

Status: offline


Registered: 01/08/13
Posts: 13
I checked my MySQL database is UTF-8, attach screenshots(http://www.chunxiao.me/xweb/image/a1.png ; http://www.chunxiao.me/xweb/image/A2.png)
I published in Geeklog.net Chinese comments, are also on display???????? "Geeklog is the official website also does not support the Chinese-language content. I recognize Geeklog program may not support the Chinese, perhaps the the Geeklog program PHP file is not strictly support UTF-8.
Could you check the recent the Geeklog program files in the new version to fix the error.

The Geeklog Chinese enthusiast community website(http://cn.chunxiao.me) My personally official blog: http://www.chunxiao.me
 
Profile Email
 Quote
::Ben
 01/09/13 04:36AM  
+++++
Full Member

Status: offline


Registered: 01/14/05
Posts: 1442
To convert your Geeklog to utf-8 you can find inspiration on:

- http://www.geeklog.net/article.php?story=200410120657418

- http://geeklog.fr/wiki/iso-8859-to-utf8

We speak french on http://geeklog.fr
 
Profile Email Website
 Quote
Laugh
 01/09/13 09:29AM  
AAAAA
Admin

Status: offline


Registered: 09/27/05
Posts: 998
Your right Geeklog.net doesn't support Chinese characters Oops!

We need to convert our db over.

Your database may be utf-8 but are all the tables? Make sure the tables are utf-8. If you checked the utf-8 option in the install and they still are not then you have come across a bug (which has been submitted already). You will have to manually convert the tables

On my development server the utf-8 option works for me in the install and I can save chinese characters in comments and stories.

Visit Ben's links for more information on how to do this

 
Profile Email Website
 Quote
chunxiao
 01/10/13 12:41AM  
+----
Newbie

Status: offline


Registered: 01/08/13
Posts: 13
Big Grin Today, I view the MySQL database table, the original codes are "latin1_swedish_ci I modify Stories library table structure will change" latin1_swedish_ci "to" UTF8_general_ci, I re-published the Chinese article, this time can be displayed.
However, when I install Geeklog (installed three or four times), I remember all the UTF-8 option is checked, but still "latin1_swedish_ci" .. I think Geeklog installer appears bugs. Should be checked and corrected.

The Geeklog Chinese enthusiast community website(http://cn.chunxiao.me) My personally official blog: http://www.chunxiao.me
 
Profile Email
 Quote
Laugh
 01/10/13 09:10AM  
AAAAA
Admin

Status: offline


Registered: 09/27/05
Posts: 998
You are correct it is a bug. I cannot reproduce it (I am on a Windows Server) but another person reported similar problems. Can you let us know what OS you are using along with versions of your web server, php and mysql?

Thanks

Tom

 
Profile Email Website
 Quote
chunxiao
 01/10/13 11:06PM  
+----
Newbie

Status: offline


Registered: 01/08/13
Posts: 13
Server operating system is Linux, the system architecture is X86_64; MySQL version 5.1.66-cll; PHP version 5.2.17; the PERL version is 5.8.8; Apache version is 2.0.63
I also found that the site name and slogan can not be filled in either English or Chinese. But you can modify the database table to fill in either English or Chinese, all OK. Attach screenshots (http://www.chunxiao.me/xweb/image/geeklogbug/01.png
http://www.chunxiao.me/xweb/image/geeklogbug/02.png)
Crawls the web search engine spider simulation, Title is blank. Perhaps this is a new bug.

thanks

chunxiao.

The Geeklog Chinese enthusiast community website(http://cn.chunxiao.me) My personally official blog: http://www.chunxiao.me
 
Profile Email
 Quote
ivy
 01/11/13 06:04AM  
+++++
Full Member

Status: offline


Registered: 11/25/04
Posts: 169
This is not a bug.
Please install after setting MySQL's collation "utf8_general_ci".

Geeklog works on multi byte languages.
e.g.
http://www.jtb-gts.com (English/Chinese/Korean)
http://www.geeklog.jp (Japanese)

Geeklog Japanese http://www.geeklog.jp
 
Profile Email Website
 Quote
kobab
 01/11/13 08:04AM  
++++-
Regular Poster

Status: offline


Registered: 02/22/10
Posts: 73
According to one of Geeklog Japanese core member, Debian default install makes MySQL's collation latin_swedish_ci. Maybe this occurs depending on server OS' distribution, version or settings etc.

Thus, in case of multi byte language environment, we need to check if MySQL's collation is utf8_general_ci before Geeklog installation. This is our Japanese community's understanding. This is not a Geeklog's bug.


Meanwhile, I am please to know Geeklog has been used for Chinese language as well.

 
Profile Email
 Quote
chunxiao
 01/11/13 08:54AM  
+----
Newbie

Status: offline


Registered: 01/08/13
Posts: 13
Big Grin I recently with Geeklog program, the establishment of a Geeklog Chinese lovers community site (site name Hanyu Pinyin is " Zhi Le Gong Yuan " ).
URL is http://cn.chunxiao.me . Welcome to visit!







The Geeklog Chinese enthusiast community website(http://cn.chunxiao.me) My personally official blog: http://www.chunxiao.me
 
Profile Email
 Quote
chunxiao
 01/11/13 09:18AM  
+----
Newbie

Status: offline


Registered: 01/08/13
Posts: 13
I've modified by manually "professional" theme folder under "header.thtml" file, and can show the Title and slogan. Facilitate the search engines crawl and included. Big Grin

The Geeklog Chinese enthusiast community website(http://cn.chunxiao.me) My personally official blog: http://www.chunxiao.me
 
Profile Email
 Quote
Laugh
 01/11/13 10:54AM  
AAAAA
Admin

Status: offline


Registered: 09/27/05
Posts: 998
Quote by: kobab

According to one of Geeklog Japanese core member, Debian default install makes MySQL's collation latin_swedish_ci. Maybe this occurs depending on server OS' distribution, version or settings etc.

Thus, in case of multi byte language environment, we need to check if MySQL's collation is utf8_general_ci before Geeklog installation. This is our Japanese community's understanding. This is not a Geeklog's bug.



At the very least it sounds like we should at least inform the user in the docs to make sure the collation of their database is utf-8.

 
Profile Email Website
 Quote
ivy
 01/11/13 11:01AM  
+++++
Full Member

Status: offline


Registered: 11/25/04
Posts: 169
Only "utf8_general_ci"

utf8_unicode_ci ... garbled characters in part.

Geeklog Japanese http://www.geeklog.jp
 
Profile Email Website
 Quote
kobab
 01/11/13 11:39AM  
++++-
Regular Poster

Status: offline


Registered: 02/22/10
Posts: 73
At the very least it sounds like we should at least inform the user in the docs to make sure the collation of their database is utf-8.

Indeed. This makes Geeklog more user friendly rather than insisting "this is not a bug". Hope this would be included in wiki.geeklog.net installation page or readme docs in the near future.

 
Profile Email
 Quote
ivy
 01/11/13 11:47AM  
+++++
Full Member

Status: offline


Registered: 11/25/04
Posts: 169
I guess this is all of Japanese CMS user's understanding.

Japanese wiki for installation:
http://wiki.geeklog.jp/index.php?title=Install14

Encode: UTF-8 Unicode (utf8)
Collation: utf8_general_ci

Geeklog Japanese http://www.geeklog.jp
 
Profile Email Website
 Quote
chunxiao
 01/12/13 09:09PM  
+----
Newbie

Status: offline


Registered: 01/08/13
Posts: 13
I think you said it right.Because my website host Server character set UTF-8 Unicode (utf8) ,server connection proofreading "utf8_general_ci". I put my Geeklog site database table structure was revised to "utf8_general_ci", after the test, the successful realization of the Chinese, Japanese, Vietnamese, Korean, Thai, Arabic, Farsi, and other non-Latin alphabet language support, but does not support Lao (a Southeast Asian country, which borders China); Mongolian and Tibetan are not tested.
I use Cpanel host in the United States, not on behalf of the Chinese mainland. Although I come from China mainland, but In the Internet field, the Chinese mainland is a very different very special Internet environment.

The Geeklog Chinese enthusiast community website(http://cn.chunxiao.me) My personally official blog: http://www.chunxiao.me
 
Profile Email
 Quote
chunxiao
 01/12/13 09:22PM  
+----
Newbie

Status: offline


Registered: 01/08/13
Posts: 13
In the field of Internet, Our mainland China use GBK character set, the main support for Simplified Chinese; Hong Kong and Taiwan use Big5 character set, the main support for Traditional Chinese.

The Geeklog Chinese enthusiast community website(http://cn.chunxiao.me) My personally official blog: http://www.chunxiao.me
 
Profile Email
 Quote
First | Previous | 1 2| Next | Last
Content generated in: 1.00 seconds
New Topic Post Reply

Normal Topic Normal Topic
Sticky Topic Sticky Topic
Locked Topic Locked Topic
New Post New Post
Sticky Topic W/ New Post Sticky Topic W/ New Post
Locked Topic W/ New Post Locked Topic W/ New Post
View Anonymous Posts 
Able to post 
Filtered HTML Allowed 
Censored Content